FreeBSD won't boot after fresh install

paulfxh

Member


Messages: 39

I haven't used FreeBSD for some time, but I'm currently trying to install it on my Dell Dimension E520 (nVidia GeForce 7300 LS, 3G RAM).
I have a number of other OSes on the same machine so I'll be trying to incorporate FreeBSD into a multiboot system.
As far as I can tell, everything is fine with the installation from DVD (FreeBSD 8.1) but when I try to boot it, it gets as far as

Code:
FreeBSD/i386 bootstrap loader, Revision 1.1
(root@almeida.***.*******.***, Monday Jul 19, 01:59:01 UTC 2010)
where it pauses for an hour or more. Then eventually, it tells me that it

Code:
can't load 'kernel'
In the limited TTy that then shows up, typing either
[cmd=]boot /boot/kernel/kernel[/cmd]
or
[cmd=]load /boot/kernel/kernel[/cmd]
produces the message

Code:
can't find '/boot/kernel/kernel'
When I type [cmd=]lsdev[/cmd] I get

Code:
cd devices:
disk devices:
     disk0:   BIOS drive C:
pxe devices:
OK
I don't know if this signifies that the disk (or partition) that FreeBSD is installed on (ad4s3) is not being seen as I presume that C: refers to ad4s1.

Note that I have used a variety of boot managers to try to boot FreeBSD 8.1 on this machine including Grub2 (Ubuntu Linux), Bootman (Haiku OS) and the FreeBSD boot manager but all give the same result.

Can anybody help me resolve this problem?
Thanks
 
OP
OP
paulfxh

paulfxh

Member


Messages: 39

Just to add to what I had earlier written:
Using the exact same FreeBSD 8.1 DVD, I was able to install the OS on another of our computers (Dell Dim 9200), which similarly holds various OSes, without any problems.
This certainly suggests that it's not the installation medium nor my lack of FreeBSD experience that's causing this problem.
The major hardware differences between the two computers are:
Dimension 9200 has an Intel C2D processor @2.13 GHz, 4GB of RAM, a nVidia Geforce 210 graphics card and two 250GB Seagate HDDs.
The Dimension E520 has an Intel C2D processor @1.86GHz, 3GB of RAM, a nVidia Geforce 7300 LE graphics card and one 300 GB Western Digital HDD.

Nice that I could get it working on at least one machine but I'm still very puzzled as to why it won't boot on the E520.
 

ahavatar

Active Member

Reaction score: 22
Messages: 198

When I installed FreeBSD, I didn't install the boot loader, and after finishing instllation, I booted Ubuntu and configure GRUB2 setting for FreeBSD and then I booted FreeBSD succesfully. Can you show us your GRUB2 setting on Ubuntu?
 
OP
OP
paulfxh

paulfxh

Member


Messages: 39

ahavatar said:
When I installed FreeBSD, I didn't install the boot loader, and after finishing instllation, I booted Ubuntu and configure GRUB2 setting for FreeBSD and then I booted FreeBSD succesfully. Can you show us your GRUB2 setting on Ubuntu?
Thanks for your reply, however, I'm fairly certain the problem is not in Grub, particularly as I get the exact same behaviour irrespective of which boot manager I use.
In addition, booting DOES actually start, which wouldn't happen if I'd messed up the boot manager. The problem seems to be that boot files on the FreeBSD partition (particularly /boot/kernel/kernel) is not found.
Nevertheless, here's what I've added to /boot/grub/grub.cfg in Ubuntu to try to boot FreeBSD
Code:
menuentry "FreeBSD 8.1" {
	set root='(hd0,msdos3)'
	chainloader +1
}
Note that I use EXACTLY the same entry in grub.cfg on the other computer where FreeBSD boots fine.
 

ahavatar

Active Member

Reaction score: 22
Messages: 198

I run Ubuntu 10.10 (10.04 is same), in my /etc/grub.d/40_custom I added:
Code:
menuentry "FreeBSD 8.1-STABLE" {
	set root=(hd0,2)
	chainloader +1
}
and "sudo update-grub" will add FreeBSD to your Grub2 setting. Note that the 2nd partition is FreeBSD in my case. You can change the number to fit your setting.
 
OP
OP
paulfxh

paulfxh

Member


Messages: 39

Thanks again for the reply.
However, once again, this is not a Grub-related problem.
Indeed, I have now resolved the issue by making a change in the BIOS. Although there is only one HDD, the default setting in the BIOS for the HDD was RAID On.
According to Dell, this improves system performance.
However, when I changed this setting from RAID On to ATA, FreeBSD became bootable without any problems.
With the exception of Windows, both of the other OSes also booted fine. Windows, however, just bluescreens complaining about a change to the hard drive controller.
So, looks like this will have to be re-installed.
 
Top