Solved FreeBSD vs.13 installation from bootable USB fails with 'can't find /etc/hostid' + 'can't find /boot/entropy'

Hello everyone at forums.FreeBSD,

the machine I'm trying to install FreeBSD vs.13.0 onto is an HP Elitebook laptop (my first time ever with FreeBSD); I correctly burned an USB stick, using a 'FreeBSD-13.0-RELEASE-amd64-memstick.img' for the purpose.

The HP Elitebook doesn't have the 'Legacy BIOS' option and YES, I excluded the Secure BIOS setup + I excluded the TPM Embedded Security, and YES I tried to change the resolution with OK gop set #[0-4 options], everything to no avail...

I already read ALL the posts here in the forum relating to the installation problem related to the sudden stop of the 'Loading kernel...' operation after pushing '1. for Boot Multi user [Enter]' during installation (I am following the official installation procedure from 'Chapter 2.Installing FreeBSD').

It gets stuck at the 'can't find /boot/entropy' + 'can't find /etc/hostid' after indicating the 'masks 0x00ff0000, etc.' (last row shown in the loading stacktrace before halting).
The situation is the same as in the attached image, i.e., a screenshot taken from another Post thread (link): FreeBSD 12.1 fresh install on AMD64 with new disks says can not find /boot/entropy

Does anyone have the slightest idea on how to solve the issue?

PS. please, if you suggest a solution, also will you take care to write a simple step-by-step procedure?

(Thank you in advance)
 

Attachments

  • freeBSD-suspended.png
    freeBSD-suspended.png
    163.1 KB · Views: 143
Thank you for your precise indication.

I was able to burn on a USB the updated/debugged image for FreeBSD 13.0 and now the installation procedure works like a charm.

For those who find themselves in the same situation, this is the link for most recent -current and -stable vs.

https://download.freebsd.org/ftp/snapshots/ISO-IMAGES/13.0/

PS. as further suggested from SirDice (read below), better to rely on the -STABLE vs.
I used the following USB image:

FreeBSD-13.0-STABLE-amd64-20211111-7647baa1e8f-248036-memstick.img
 
The exact same problem still persists with FreeBSD-13.0-STABLE-amd64-20211118-3a15ccadf87-248076-memstick.img on ASUS B560-Plus motherboard with an i3-10100 in iGPU mode.
 
Exactly this Stable version fixed it for me but not an ASUS board. Use HP i7 9700 with UHD-630.
However I'm not happy to be forced to Stable. I'm using Release for 2 years now and are super happy with it. Very stable
and never any issue other than my old friend drm-kmod. Really would like to stay on Release.
Now with my new toy (I7, 8 core 32 GB) only Stable boots. So how stabel is Stable. Is it save to use it for day to day work or is it more
like a rolling Linux distro where it is not a question if it breaks than when it breaks?
Really unsure what to do about it.
 

SirDice

Administrator
Staff member
Administrator
Moderator
Is it save to use it for day to day work or is it more
like a rolling Linux distro where it is not a question if it breaks than when it breaks?
I've been running -STABLE since the 3.0 era. Never had much issues with it. Nothing a fresh source pull and a new build didn't fix. While -STABLE is certainly a development version, you can view it as the alpha release of the next minor version.
 
Thanks. (I was confused by that link previously appearing in a headless context; I didn't imagine a photograph of something headless.)
 
Top