Solved freebsd-version(1) and uname(1) different?

Hi all,

I ran a uname(1) on one of my FreeBSD hosts this morning and saw that I was running 12.0-RELEASE-p2:
Code:
root@bil-desktop:~ # uname -a
FreeBSD bil-desktop 12.0-RELEASE-p2 FreeBSD 12.0-RELEASE-p2 GENERIC  amd64

I thought I'd upgraded this to latest, so went ahead and did a freebsd-update(1):
Code:
root@bil-desktop:~ # freebsd-update fetch
src component not installed, skipped
Looking up update.FreeBSD.org mirrors... 3 mirrors found.
Fetching metadata signature for 12.0-RELEASE from update4.freebsd.org... done.
Fetching metadata index... done.
Inspecting system... done.
Preparing to download files... done.

No updates needed to update system to 12.0-RELEASE-p3.

Weird, I thought...Maybe my kernel or userland are out of sync?

Code:
root@bil-desktop:~ # freebsd-version -ku
12.0-RELEASE-p3
12.0-RELEASE-p3

Nope, apparently I'm running 12.0-RELEASE-p3 kernel and userland...

I've tried this on my FreeBSD work VM and uname(1) happily reports 12.0-RELEASE-p3. Both the first machine and my work VM were installed with FreeBSD 11.1-RELEASE and have been incrementally upgraded together using freebsd-update(1), so I'm not sure why this one is reporting the wrong version in uname(1)?
 
Top