• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

freebsd-update on raspberry pi?

Mattias Fransson

New Member


Messages: 1

#1
I just got FreeBSD running on a raspberry pi. I tried a few different ISO files before finding one I could successfully boot.

The one that worked for me was FreeBSD-11.0-RC3-arm-armv6-RPI2.img.

After install I realised there is not only 11.0-RC3 available, but also 11.0-RELEASE.

I'm brand new to FreeBSD, but I figured I could upgrade form RC3 to RELEASE using:

Code:
# freebsd-update -r 11.0-RELEASE upgrade
src component not installed, skipped
Looking up update.FreeBSD.org mirrors... 4 mirrors found.
Fetching public key from update4.freebsd.org... failed.
Fetching public key from update5.freebsd.org... failed.
Fetching public key from update6.freebsd.org... failed.
Fetching public key from update3.freebsd.org... failed.
No mirrors remaining, giving up.
It does not work as you can see.

Looking at http://update.freebsd.org/11.0-RELEASE/ in my web browser I do see that there are update files, but only for AMD64 and i386.

Is it not possible to use freebsd-update(8) for ARM? Or should I just use another server to get the updates from?
 
Top