Hi !
I want to connect my freebsd server to ES-16-XG switch with firmware 1.9.2 with the help of an portchannel
with cisco switch ist works without a problem but with ubiquiti switch i have troubles.
If i change the portchannel to static also not work
or if i change portchannel to static and change on freebsd the laggproto to loadbalance the portchannel is then on both sides up but doesnt work !
Here my config and show commands:
Freebsd:
ES-16-XG:
show lacp partner 0/7
#show lacp partner 0/8
show port-channel 4
Cisco
cisco config looks like this and it work:
www.freebsd.org
on freebsd lagg interface:
ifconfig -v lagg1
I want to connect my freebsd server to ES-16-XG switch with firmware 1.9.2 with the help of an portchannel
with cisco switch ist works without a problem but with ubiquiti switch i have troubles.
If i change the portchannel to static also not work
or if i change portchannel to static and change on freebsd the laggproto to loadbalance the portchannel is then on both sides up but doesnt work !
Here my config and show commands:
Freebsd:
Code:
fconfig_lagg1="laggproto lacp laggport ql0 laggport ql1 X.X.X.X/24"
lagg1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO>
ether 94:40:c9:5f:db:a0
inet X.X.X.X netmask 0xffffff00 broadcast Y.Y.Y.255
laggproto lacp lagghash l2,l3,l4
laggport: ql0 flags=0<>
laggport: ql1 flags=0<>
groups: lagg
media: Ethernet autoselect
status: active
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
ES-16-XG:
Code:
interface lag 4
description 'Server'
load-interval 30
switchport mode access
switchport access vlan 50
exit
interface 0/7
addport 3/4
exit
interface 0/8
addport 3/4
exit
interface 0/7
description 'Server'
switchport mode access
switchport access vlan 50
exit
interface 0/8
description 'Server'
switchport mode access
switchport access vlan 50
exit
show lacp partner 0/7
Code:
Sys System Admin Prt Prt Admin
Intf Pri ID Key Pri Id State
------- ----- ----------------- ----- ----- ----- -----------
0/7 32768 94:40:C9:5F:DB:A0 306 32768 5 ACT|AGG|LTO
show lacp partner 0/8
#show lacp partner 0/8
Code:
Sys System Admin Prt Prt Admin
Intf Pri ID Key Pri Id State
------- ----- ----------------- ----- ----- ----- -----------
0/8 32768 94:40:C9:5F:DB:A0 306 32768 6 ACT|AGG|LTO
show port-channel 4
Code:
Local Interface................................ 3/4
Channel Name................................... 4
Link State..................................... Down
Admin Mode..................................... Enabled
Type........................................... Dynamic
Port-channel Min-links......................... 1
Load Balance Option............................ 3
(Src/Dest MAC, VLAN, EType, incoming port)
Mbr Device/ Port Port
Ports Timeout Speed Active
------ ------------- --------- -------
0/7 actor/long 10G Full False
partner/long
0/8 actor/long 10G Full False
partner/long
Cisco
cisco config looks like this and it work:
Chapter 34. Advanced Networking
Advanced networking in FreeBSD: basics of gateways and routes, CARP, how to configure multiple VLANs on FreeBSD, etc
Code:
interface TenGigt0/1
channel-group 1 mode active
channel-protocol lacp
!
interface TenGigt0/2
channel-group 1 mode active
channel-protocol lacp
on freebsd lagg interface:
ifconfig -v lagg1
Code:
lagg1: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
options=507bb<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,JUMBO_MTU,VLAN_HWCSUM,TSO4,TSO6,LRO,VLAN_HWFILTER,VLAN_HWTSO>
ether 94:40:c9:5f:db:a0
inet X:X:X:X netmask 0xffffff00 broadcast Y:Y:Y:.255
laggproto lacp lagghash l2,l3,l4
lagg options:
flags=10<LACP_STRICT>
flowid_shift: 16
lagg statistics:
active ports: 0
flapping: 0
lag id: [(0000,00-00-00-00-00-00,0000,0000,0000),
(0000,00-00-00-00-00-00,0000,0000,0000)]
laggport: ql0 flags=0<> state=45<ACTIVITY,AGGREGATION,DEFAULTED>
[(8000,94-40-C9-5F-DB-A0,0132,8000,0005),
(FFFF,00-00-00-00-00-00,0000,FFFF,0000)]
laggport: ql1 flags=0<> state=c5<ACTIVITY,AGGREGATION,DEFAULTED,EXPIRED>
[(8000,94-40-C9-5F-DB-A0,0132,8000,0006),
(FFFF,00-00-00-00-00-00,0000,FFFF,0000)]
groups: lagg
media: Ethernet autoselect
status: active
nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>