freeBSD problem

imtheroot

New Member


Messages: 1

Hello, I use mobaxterm to connect to my VPS with FreeBSD every time I change something in the files a window pops up saying "SSH transfer: Password for root@ip" Is there a way to turn this off? Thanks in advance!
 

Attachments

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 7,672
Messages: 30,574

FreeBSD 10.4 has been End-of-Life since October 2018 and is not supported any more. Upgrade as soon as possible.

Also don't login with root directly, there's a reason why this has been turned off by default.
 

drhowarddrfine

Son of Beastie

Reaction score: 1,217
Messages: 3,235

When you post a thread here on this forum, please write a descriptive title. "freeBSD problem"[sic], in most cases, is the description of every thread here and you would be wasting the time of everyone who cannot help you.
 

pyret

Member

Reaction score: 55
Messages: 86

That is not a FreeBSD problem, but a MobaXterm setting. Have you gone to "Settings" then "Configuration" then on the "General" tab go to "MobaXterm passwords management"?
 

roccobaroccoSC

Well-Known Member

Reaction score: 95
Messages: 426

Hello, I use mobaxterm to connect to my VPS with FreeBSD every time I change something in the files a window pops up saying "SSH transfer: Password for root@ip" Is there a way to turn this off? Thanks in advance!
You could use SSH keys.
First generate a key for the client, using ssh-keygen()
Then add the public key as string on the server in the home directory of the user you login with: ~/.ssh/authorized_key
A server restart is NOT necessary.

For the copying part there is a script that automates it: ssh-copy-id().
 
Top