Solved FreeBSD on HP ProBook 6470B? (boot trouble after install (uefi-csm))


New Member

Messages: 1


I was trying to install FreeBSD 10.2-Release on my ProBook 6470B, well UEFI doesn't boot the installer, it crashes and I found a bug report on a probook g1 that was fixed a few months ago. Well I also found out root on ZFS and UEFI was a no-go so I scratched UEFI thoughts. I booted in CSM mode instead.

In CSM/legacy mode I get the non-UEFI boot loader and all would seem to work just fine. But sometimes I get a error 19 when mounting the rootfs of the installer. It did work fine a few times though.

Also I see a lot of "noperiph rescan already queued" messages, those I found out was connected to the eSATA port, so disabling it and the HP upgrade port or what ever useless ports I found in the UEFI and those messages was gone.

When I after a lot of fiddling with UEFI and booting, I actually got it installed, first I tried Root-on-ZFS and GPT. That didn't work, so installed again.. this time GPT and UFS. The install went smooth, but no working boot. No matter what I tried, it just would not want to boot from the hard drive. It was the same on 10.2-RELEASE, 9.3-RELEASE, 11-CURRENT. (latest image just to test).

When I try to boot it, the screen just blinks and doesn't even show the FreeBSD boot loader. Then it restarts and so it seems to do regardless of version.

Now the problem is I guess it's some kinda UEFI/BIOS error or busted boot loader on this hardware. But as it boots the installer fine but not after installation I'm kinda lost and I got no idea how to debug a boot loader on the laptop.

Ubuntu installs UEFI safe booting and legacy fine, and works fine. But I would like to try FreeBSD not use Ubuntu. I would like to use a release version as the computer will be used mainly with 3G to update household inventory at an offsite location and I will not always be the one using the computer.

Hopefully this is possible. Otherwise I'll have to use Linux. But I would like to use FreeBSD cause of the separation of base and userspace.


Found this post. By manually setting ada0 active system booted like it should. This with 9.3-Release. Haven't tried with 10.2-Release yet, but I would guess its the same issue.