Solved FreeBSD Kernel PANIC >> OrangePi-R1-Plus (RK3328 AARCH64 )

alfa

New Member

Reaction score: 2
Messages: 10

Hi, I am trying to boot FreeBSD 13.0-CURRENT on RK3328 based new OrangePi R1 Plus (seems like clone of NanoPi R2s)
So I tried @ganbold 's FreeBSD image and official aarch64 images on it but I had kernel panic all of them. I could not find u-boot for FreeBSD supported OrangePi r1 plus rk3328.
I tried @ganbold's uboot and I picked one from OpenWRT's build repo. So what is the problem?
Any help would be appreciated.

Kernel panic logs seen by video
>> I wrote ganbold's uboot image shown below
For with miniloader:
Code:
dd if=idbloader.img of=sdb seek=64
dd if=uboot.img of=sdb seek=16384
dd if=trust.img of=sdb seek=24576

>> I wrote OpenWRT's uboot shown below
Code:
Booting from an SD card on Pine64 Rock64 (RK3328)
=================================================
https://github.com/trini/u-boot/blob/master/doc/README.rockchip

For Rock64 rk3328 board the following three parts are required:
TPL, SPL, and the u-boot image tree blob.

  - Write TPL/SPL image at 64 sector

    => sudo dd if=idbloader.img of=/dev/mmcblk0 seek=64

  - Write u-boot image tree blob at 16384 sector

    => sudo dd if=u-boot.itb of=/dev/mmcblk0 seek=16384

Regards.


https://people.freebsd.org/~ganbold/FreeBSD-13.0-CURRENT-arm64-aarch64-nanopi-r2s.img.xz
Index of /~ganbold/nanopi-r2s/
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,608
Messages: 36,269

-CURRENT is an unsupported development version and 13.0-CURRENT doesn't exist any more. -CURRENT has moved on to 14.0, there's now a stable/13 branch and there will be a 13.0-RELEASE soon.

Which means you're working on an old copy of 13.0-CURRENT and this bug may have already been fixed.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 10,608
Messages: 36,269

There are 13.0-ALPHA images, those are newer than the 13.0-CURRENT images. The release of 13.0 is just around the corner. The first beta releases are made right now and should appear shortly.


I'm not saying your issue is resolved in these, I honestly don't know, but there's no point in trying to track down an error in an old snapshot.
 
OP
alfa

alfa

New Member

Reaction score: 2
Messages: 10

I have solved the problem with appropriate u-boot images
posted by felix
 
Top