FreeBSD crashes when initialising Slim


I hope you are well.

I am new to FreeBSD. I am trying to configure a xfce GUI with Slim login. I have applied the below config but when I initialise Slim FreeBSD crashes and generates a crash dump (which is huge). Any help would be greatly appreciated.

pkg install -y nano
pkg install -y xorg
pkg install -y xfce
pkg install -y slim slim-themes
sysrc dbus_enable-YES
sysrc hald_enable-YES
sysrc slim_enable-YES
sysrc sound_load-YES
sysrc snd_hda_load-YES
:/home/RANCID # vi .xinitrc
exec /usr/local/bin/startxfce4​
#pkg install -y firefox libreoffice gimp thunderbird vlc
# /usr/local/etc/vi slim.conf
deafault_user RANCID​
# cd /home/RANCID
:/home/RANCID # pw groupmod video -m RANCID

Many thanks
tail -60 /var/log/Xorg.0.log
cat ~/.xsession-errors

Do you have a xorg.conf file?
Do you need drm drivers?
Did the Xfce installation complete successfully?

It seems a better way:
exec /usr/local/bin/startxfce4 --with-ck-launch

Hald is deprecated.
I just installed lightdm and loaded up on desktops, it was eaier to set up then I thought and actually worked on first reboot after install. the only thing is that xfce4 takes over the image on the login manager using whatever one has for a desktop image in xfce4, which I have to figure out how to get that to stop.

point being if you have too much issues and just want to dump that then try lightdm

install these three
lightdm-1.32.0_1               Lightweight Display Manager
lightdm-gtk-greeter-2.0.8_3    GTK+ greeter for LightDM
lightdm-gtk-greeter-settings-1.2.2_1 Settings editor for LightDM GTK+ Greeter
sudo sysrc lightdm_enable="YES"
run sudo lightdm-gtk-greeter-settings from the cli to set up the login manager save, then

just make sure you have the desktop files in in xsessions dir if you have more thatn one DZ/WM if not just copy one then modify it for that one that is missing.

as far as slim I remember I had to add something in .xinitrc but it's been years since I've used FBSD so I forgot what that was and that is why I tried lightdm instead for the most part, and it doesn't matter what is in my .xinitrc

for XFCE4

in /etc/fstab
proc /proc procfs rw 0 0

make sure user is has video group
pw groupmod video -m userName

you can disable slim in rc.conf then see if Xfce4 is working first on the command line. login -> startxfce4 before moving to adding something else in the line