FreeBSD 6.3 and Samba Network Browsing

I'm having a problem with local network browsing. This has occurred for me from the same FBSD installation as a Samba client on both a WindowsNT4 domain and a FBSD Samba PDC. I am currently a member of the Samba PDC.

I had trouble joining the Samba domain with net rpc join -S servername -U root, when I entered -S localserveripaddress it took right off and joined no problem.

I can ping localserveripaddress no problem.

I can wbinfo -u and all of the other commands no problem. I can log in as a winbind client no problem. I can access the Samba PDC from Winblows stations no problem. I can log in with Winblows no problem.

It just that when I am in FBSD, and use Nautilus to browse the network, sometimes it works, sometimes it does not. It does not most of the time. To me it sounds like a name-resolution problem, but I think it should work by broadcast. I have been thinking about adding wins to to Samba PDC, but before I do, I would like to get this working by broadcast which I think it should. Using Nautilus to browse is really the only problem that I am having.

Simple home network: DHCP is by a router which is connected to the internet. The Samba PDC is on a static IP. All other stations are using DHCP.

I have searched the Internet just like I aways do before coming here to post.

Is there something I should be setting in resolv.conf or something else? I have seen information about searching local domain first entries, but don't have it quite figured out yet. What can I do to make a FBSD samba client use broadcasts if that is my problem. Thanks in advance.
I think I solved My Own Problem

I think I solved my own problem. It was netbios name resolution. Changed the netbios name resolve order, and netowrk is working SO MUCH BETTER.