Solved FreeBSD 13.1-R. nVidia-xorg - Segmentation fault. Caught signal 11

Hello forum.
I'm having some issues with my WS and FreeBSD with NVidia.
I was struggling to launch NVidia gpu with Xorg and eventually I did it ( silly mistake ) but once I got into my wm (i3-gaps) set up my dual monitors, refresh rate etc with nvidia-settings I rebooted my pc and now I have this error:
Code:
(EE) Segmentation fault at address 0x0
(EE) Fatal server Error:
(EE) Caught signal 11 (Segmentation fault). Server aborting.
I don't have any xorg config files in /etc/X11/ as WM wouldn't start and gives me no screen found error.
I have only one file for xorg where I had my PCI bus written down ( wouldn't start without it ).
FreeBSD 13.1-Release installed few days ago so latest iso, nvidia-driver latest one, xorg 1.21.1.4
I could use it without NVidia for now but I'm getting scfb drivers so my screen res is 800x600 and I have 4k screens ... maybe is there an option how to use 4k full res without NVidia and scfb. I have Xeon CPUs so no integrated gpu but my mb have something integrated ( Asus Z10-PE D16 WS ).
Thank You.
 
CPU - Intel Xeon E5-2690 v4 x2 - just in case you need cpu info.
GPU: nVidia Titan V CEO Edition.
Driver - 510.60.02 as its the latest one and thats what i used with portmaster
Xorg has no config - i deleted after i had this error and thought and only one config for xorg is:
Code:
Section "Device"
        Identifier "NVIDIA Card"
        VendorName "NVIDIA Corporation"
        Driver "nvidia"
        BusID "PCI:2:0:0"
EndSection
And how to get that unabridged Xorg log ?
P.s im using two pc`s so i might have to retype whole config/log.

Thank You.
 
Looks similar to https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=261666#c3, I'd suggest a downgrade to nvidia-driver-470, because a workaround that we found for that issue (Option "UseDisplayDevice" "None") is not applicable to your configuration. Might be worth trying the actual lastest driver version (525.53 [beta]), but it's not packaged yet.
how do i do that ? i was looking at something last night ... but im new to FreeBSD and i dont understand how to do it with portmaster ... as it was one of ideas i wanted to try.
 
I was struggling to launch NVidia gpu with Xorg and eventually I did it ( silly mistake ) but once I got into my wm (i3-gaps) set up my dual monitors, refresh rate etc with nvidia-settings I rebooted my pc and now I have this error:
Does xorg start when ~/.nvidia-settings-rc is disabled (rename the file)?

If xorg does start please post that configuration file as well.
 
so instead of portmaster foo/bar i just do portmaster foo/nvidia-470 ?
As SirDice says use packages, the commands would be something like:
pkg delete nvidia-driver
pkg install nvidia-driver-470

If you installed nvidia-driver from source, I think the pkg delete should work, but it's been a while since I've mixed things.
 
Looks like solved!
Downgraded nvidia-driver to version 470 and reboot
Had to change
Code:
kld_list="nvidia"
to
Code:
 kld_list="nvidia-modeset"
otherwise it hungs up on "startx".

P.s. have not saved nvidia-settings file to X config file... a bit worried about it.
Thank You guys !
 

SirDice

Administrator
Staff member
Administrator
Moderator
i started to use ports and i read that its not good to mix them
You can get yourself in hot water if you have different options selected. As long as you've built the ports with all the default options set (and didn't change any of those) it should be relatively safe. One thing to note is that the ports tree defaults to 'latest' whereas the -RELEASE versions default to 'quarterly' packages. So there may be some version differences. You can select the 'latest' packages if you create a /usr/local/etc/pkg/repos/FreeBSD.conf:
Code:
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest"
}
 
You can get yourself in hot water if you have different options selected. As long as you've built the ports with all the default options set (and didn't change any of those) it should be relatively safe. One thing to note is that the ports tree defaults to 'latest' whereas the -RELEASE versions default to 'quarterly' packages. So there may be some version differences. You can select the 'latest' packages if you create a /usr/local/etc/pkg/repos/FreeBSD.conf:
Code:
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest"
}
Nice to know ... as im not trying to update to latest and sometimes i dont run updates for 6 to 12 months .. quarterly packages are the way to go.
And yes, i do sometimes change options in ports, this is the reason im using them.
 
Update after saving nvidia-settings to xorg.conf file :
I had to add bus id to this section:
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA TITAN V JHH Special Edition"
    BusID       "PCI:2:0:0"
EndSection

Otherwise errors again.
 
Update after saving nvidia-settings to xorg.conf file :
I had to add bus id to this section:
Code:
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA TITAN V JHH Special Edition"
    BusID       "PCI:2:0:0"
EndSection

Otherwise errors again.
if you do pciconf -lv and look for things with class = display. If you have more than one (say an integrated Intel and an external Nvidia card) that's likely why the BusID is needed.
 
if you do pciconf -lv and look for things with class = display. If you have more than one (say an integrated Intel and an external Nvidia card) that's likely why the BusID is needed.
My CPU`s dont have integrated graphics, but my motherboard - does... now thats makes sense.
Its nice a very nice tip to solving GPU issues.
Thank You.
 
  • Like
Reactions: mer
Top