Solved Freebsd 12, driver to use with RTL8812AU?

roccobaroccoSC

Aspiring Daemon

Reaction score: 163
Messages: 647

A quick google search found this driver on Github: https://github.com/s3erios/urtwm
It seems it's not included in the ports tree, so you would have to follow the instructions in Github to compile and install it.

Do you have the driver installed?
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

A quick google search found this driver on Github: https://github.com/s3erios/urtwm
It seems it's not included in the ports tree, so you would have to follow the instructions in Github to compile and install it.

Do you have the driver installed?
I thought that loading module rtwn_usb is enough.
Here is something about it:

I'll try to compile and install it from link you gave me.. thanks.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 163
Messages: 647

What loading modules does is, it tells the kernel to load a module file from the disk. If the file is not there, the kernel has nothing to load.
You need to install the module package first, then the kernel will be able to find it.

Of course, many modules are already in the base system and you don't need packages for them, but urtwm is apparently not one of them.
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

What loading modules does is, it tells the kernel to load a module file from the disk. If the file is not there, the kernel has nothing to load.
You need to install the module package first, then the kernel will be able to find it.

Of course, many modules are already in the base system and you don't need packages for them, but urtwm is apparently not one of them.
kldload rtwn_usb gives error:
Code:
kldload: can't load rtwn_usb: module already loaded or in kernel
So I thought module was already loaded.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 163
Messages: 647

I have just read the link you posted. Indeed, the rtwn_usb driver should support your adapter according to documentation.

First you need to see if the device is detected properly. After loading the module, see if the device is listed:
Code:
usbconfig list
Is there any related error message in the output of
Code:
dmesg
And also - post the specific error messages here (if any).
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 163
Messages: 647

If the driver is loaded - verify this with:
Code:
kldstat | grep rtwn
Then you need to plug in the device and see if it has been detected:
Code:
dmesg | tail
Try to find the network interface:
Code:
ifconfig -l
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

Code:
~ % sudo usbconfig list
ugen4.1: <ATI OHCI root HUB> at usbus4, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen1.1: <ATI EHCI root HUB> at usbus1, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen2.1: <ATI OHCI root HUB> at usbus2, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen3.1: <ATI EHCI root HUB> at usbus3, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen5.1: <ATI OHCI root HUB> at usbus5, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen0.1: <ATI OHCI root HUB> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=SAVE (0mA)
ugen6.1: <ATI EHCI root HUB> at usbus6, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (0mA)
ugen0.2: <vendor 0x1241 product 0x1203> at usbus0, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON (100mA)
ugen0.3: <vendor 0x170b product 0x0011> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)
ugen0.4: <Burr-Brown from TI USB Audio CODEC> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)
ugen7.1: <0x104c XHCI root HUB> at usbus7, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)
ugen7.2: <Realtek USB3.0 802.11ac 1200M Adapter> at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)
ugen7.3: <GenesysLogic USB2.0 Hub> at usbus7, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=SAVE (500mA)
ugen7.4: <Logitech USB Optical Mouse> at usbus7, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON (100mA)
ugen7.5: <GenesysLogic USB3.0 Hub> at usbus7, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)

dmesg found no error, wifi device is found.

Code:
ugen7.2: <Realtek USB3.0 802.11ac 1200M Adapter> at usbus7
Maybe there's something wrong with my rc.conf

Code:
% cat /etc/rc.conf
clear_tmp_enable="YES"
hostname="DAW"
keymap="fi.kbd"

# Network setup
ifconfig_bge0="DHCP"
wlans_rtwn_usb0="wlan0"
ifconfig_wlan0="WPA DHCP"

sshd_enable="YES"
ntpd_enable="YES"
powerd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
zfs_enable="YES"
.. or loader.conf..

Code:
% cat /boot/loader.conf
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
opensolaris_load="YES"
zfs_load="YES"

# Accept Realtek license
legal.realtek.license=ack=1

# WiFi RTL8812AU
if_rtwn_usb_load="YES"
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

Code:
% sudo kldstat | grep rtwn
 4    1 0xffffffff829fe000    1d3b8 if_rtwn_usb.ko
 5    2 0xffffffff82a1c000    26fa8 rtwn.ko
Only wired is found
Code:
ifconfig -l
bge0 lo0
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

I opened it and found out that chip is RTL8812BU not RTL8812AU like it was sold to me..🤬
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

Seems that RTL8812BU is not supported, so I mark this thread solved. 5GHz WiFi dongle recommendation for FreeBSD is welcome.
 
OP
S

s5e

Member

Reaction score: 4
Messages: 60

roccobaroccoSC

Aspiring Daemon

Reaction score: 163
Messages: 647

Just a shot in the dark. Maybe try sysctl -a | grep -i rtwn and see if you can find some useful information. Also search in /var/log for relevant logs.
Maybe give this Github driver a try (but you have to unload the builtin kernel module first).
Also, getting the bleeding edge version of FreeBSD 13 might help detect the device. But all these are long shots.
Otherwise I have no further ideas, sorry.
 

mawill

New Member


Messages: 1

.. or loader.conf..

Code:
% cat /boot/loader.conf
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
opensolaris_load="YES"
zfs_load="YES"

# Accept Realtek license
legal.realtek.license=ack=1

# WiFi RTL8812AU
if_rtwn_usb_load="YES"
It doesn't sound like it would change anything in this case, but the line is mentioned in the urtwnfw(4) man page as:
Code:
legal.realtek.license_ack=1
 
Top