MATE FreeBSD 12.1-RELEASE-p3 - mouse click no longer works after pkg upgrade (Mate Desktop)

fredat

New Member


Messages: 11

I have been using FreeBSD 12 with Mate in VirtualBox (on a Mac) for some time now for testing purposes. Desktop is Mate.
Yesterday I did a pkg upgrade, upgrading several components, including some from Mate.
Today I found that the mouse click no longer works. The mouse arrow moves, the icons change when the mouse arrow is over it.
When I move the mouse cursor over an application icon, its description appears.
Neither the mouse click (right or left) nor a click with the trackpad works now. I cannot start a program with it!
What can be the reason for this, which "screw I have to turn now?“
It is probably related to the mate upgrade.

I have been doing this installation for quite some time and have done several FreeBSD and pkg adddes/upgrades without any problems.

My current FreeBSD version: 12.1-RELEASE-p3

PS: I am not a FreeBSD specialist, but I was able to get FreeBSD running with X and Mate.

(Translated with www.DeepL.com/Translator - my native language is German - I am from Austria)
 

jb_fvwm2

Daemon

Reaction score: 204
Messages: 1,787

pkg install xf86-input-libinput; pkg install xv86-input-evdev; relogon? Also in my
case I had to comment out some lines in xorg.conf...
.........................................................................................
Not saying it will fix it but slight chance it will.
 

Leveret

Member

Reaction score: 9
Messages: 95

I had a problem with an invisible mouse cursor because x.org switched from devd to udev. I had to add: Option "SWCursor" "true" to my configuration file. This also happened after an upgrade.
 
OP
F

fredat

New Member


Messages: 11

pkg install xf86-input-libinput; pkg install xv86-input-evdev; relogon? Also in my
case I had to comment out some lines in xorg.conf...
.........................................................................................
Not saying it will fix it but slight chance it will.
xf86-input-libinput was installed
ixv86-input-evdev are not available - but I installed xf86-input-evdev now - is this right?
Are no change, mouse click don't work. :mad:
In VirtualBox before I had VBoxSVGA, but VirtualBox say'd this is wrong for FreeBSD, so I changes to VMSVGA without any affect. Only the automatic adjustment of the desktop resolution don't work with VMSVGA. What must I change in the X settings for change from VBoxSVGA to VMSVGA?
I think VBoxSVGA or VMSVGA has nothing to do with the mouse problem. With both VirtualBox settings the mouse click don't work.
I can't remember why I set VBoxSVGA in VirtualBox back then.
 
OP
F

fredat

New Member


Messages: 11

Next step, I add in /etc/rc.conf file:
Code:
moused_enable=”YES”
moused_type=”auto”
moused_port=”/dev/psm0″
But without any affect.

I am now at a loss - is this error in the X-org or in the Mate settings? And where exactly?
Which update/upgrade has caused this, because it has been running very well for a few months now?
 

T-Daemon

Daemon

Reaction score: 696
Messages: 1,467

xf86-input-libinput was installed
... I installed xf86-input-evdev now - is this right?
Looks good.

I have only those on my system (VM):
py37-evdev
xf86-input-evdev

Run pkg info -D xorg-server, that will display a package message, notice the kern.evdev.rcpt_mask
variable. Try setting that, eventually try 12 as value if 6 doesn’t work.

In VirtualBox before I had VBoxSVGA, but VirtualBox say'd this is wrong for FreeBSD, so I changes to VMSVGA without any affect.
I’m running myself a few FreeBSD VM’s in VirtualBox on macOS. It makes no difference if the graphics controller is set to VBoxVGA, VMSVGA, or VBoxSVGA, all are accepted (I’m using VBoxVGA), no desktop environments but light weight window managers (jwm, openbox, awesome).

What must I change in the X settings for change from VBoxSVGA to VMSVGA?
Nothing.

Next step, I add in /etc/rc.conf file:
moused_enable=”YES” moused_type=”auto” moused_port=”/dev/psm0″
Disable all of them first, if necessary re-enable moused_enable=”YES”.
 

jmos

Active Member

Reaction score: 116
Messages: 162

The update of the package "xorg-server" tells some hints, and as the mouse on my notebook didn't worked anymore, I've just checked it: "sysctl kern.evdev.rcpt_mask=6" does the trick, and adding one line to /etc/sysctl.conf ("kern.evdev.rcpt_mask=6") sets this permanently. But: I have no clue about VirtualBox - in my opinion it's just a waste of time and unusable. So, maybe your problem hasn't anything to do with the changes of this package…
 
OP
F

fredat

New Member


Messages: 11

I disabled all my taken mouse settings in /etc/rc.conf file
And add the line: kern.evdev.rcpt_mask=6 in /etc/sysctl.conf
Now it works well.

FreeBSD-nomouseclick.png
 
OP
F

fredat

New Member


Messages: 11

After a reboot it didn't work again, see that "a ghost hand" has set a # before vboxguest_enable="YES" in /etc/rc.conf.

Now with the following settings:
Code:
======================================

GNU nano 4.8       /etc/rc.conf                               
hostname="myFreeBSD"
keymap="de.kbd"
ifconfig_em0="DHCP"
ifconfig_em0_ipv6="inet6 accept_rtadv"
sshd_enable="YES"
ntpd_enable="yes"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
ntpd_sync_on_start="yes"
anacron_enable="YES"
# GNOME MATE
dbus_enable="YES"
hald_enable="YES"
# lightdm_enable="YES"
# gnome_enable="YES"
# mate_enable="YES"
#
# VirtualBox Guest

vboxguest_enable="YES"

# vboxservice_enable="YES"
# vboxservice_flags="--disable-timesync"

# USB Automount
devfs_system_ruleset="localrules"
autofs_enable="YES"

moused_enable="YES"
moused_type="auto"
moused_port="/dev/psm="

======================================

GNU nano 4.8  /etc/sysctl.conf

# $FreeBSD: releng/12.1/sbin/sysctl/sysctl.conf 337624 2018-08-11 13:28:03Z brd>
#
#  This file is read when going to multi-user and its contents piped thru
#  ``sysctl'' to adjust kernel values.  ``man 5 sysctl.conf'' for details.
#

# Uncomment this to prevent users from seeing information about processes that
# are being run under another UID.
#security.bsd.see_other_uids=0

vfs.usermount=1

kern.evdev.rcpt_mask=6

======================================
 

chicagonpg

New Member


Messages: 1

I disabled all my taken mouse settings in /etc/rc.conf file
And add the line: kern.evdev.rcpt_mask=6 in /etc/sysctl.conf
Now it works well.

View attachment 7740
I was looking for a solution and this fixed it for me. Only thing now is when I use the mouse wheel to scroll up the page it triggers the page to go back to the previous page instead of up.
 
Top