FreeBSD 11-RC1 urtwn Associated But No Traffic

dave

Well-Known Member

Reaction score: 24
Messages: 415

Hello,

I am running FreeBSD 11 RC1 on a raspberry pi 2. I have a urtwn(4) usb wifi device. I can get it associated with my access point, but it just won't seem to send/receive any traffic: not DHCP packets, and not pings if I configure it statically.

Code:
# uname -a
FreeBSD rpi2 11.0-RC1 FreeBSD 11.0-RC1 #0 r303979: Fri Aug 12 17:12:13 UTC 2016     root@releng2.nyi.freebsd.org:/usr/obj/arm.armv6/usr/src/sys/RPI2  arm
Code:
# cat /boot/loader.conf
#
#         RealTek
#
legal.realtek.license_ack=1
if_urtwn_load="YES"
Code:
# cat /etc/rc.conf
hostname="rpi2"
#ifconfig_DEFAULT="DHCP"
ifconfig_ue0="X.X.X.250 netmask 255.255.255.0"
defaultrouter="X.X.X.1"
sshd_enable="YES"
sendmail_enable="NONE"
sendmail_submit_enable="NO"
sendmail_outbound_enable="NO"
sendmail_msp_queue_enable="NO"
growfs_enable="YES"

#
#         WiFi
#
wlans_urtwn0="wlan0"
ifconfig_wlan0="WPA SYNCDHCP"
Code:
network={
          ssid="MySSID"
          psk="MyInsanelyComplexPassword"
          proto=RSN
          key_mgmt=WPA-PSK
}
Code:
# ifconfig wlan0
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
          ether 40:a5:ef:0c:ad:93
          inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255
          groups: wlan
          ssid Air channel 6 (2437 MHz 11g ht/20) bssid 28:94:0f:79:f7:90
          regdomain FCC country US authmode WPA2/802.11i privacy ON
          deftxkey UNDEF AES-CCM 3:128-bit txpower 30 bmiss 7 scanvalid 60
          protmode CTS ht20 -ampdutx ampdurx ampdulimit 64k ampdudensity 16
          -stbc wme roaming MANUAL
          media: IEEE 802.11 Wireless Ethernet MCS mode 11ng
          status: associated
          nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
Code:
# dhclient wlan0
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 3
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Code:
# ifconfig wlan0 inet X.X.X.251 netmask 255.255.255.0
# ifconfig wlan0
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
          ether 40:a5:ef:0c:ad:93
          inet X.X.X.251 netmask 0xffffff00 broadcast X.X.X.255
          groups: wlan
          ssid Air channel 6 (2437 MHz 11g ht/20) bssid 28:94:0f:79:f7:90
          regdomain FCC country US authmode WPA2/802.11i privacy ON
          deftxkey UNDEF AES-CCM 3:128-bit txpower 30 bmiss 7 scanvalid 60
          protmode CTS ht20 -ampdutx ampdurx ampdulimit 64k ampdudensity 16
          -stbc wme roaming MANUAL
          media: IEEE 802.11 Wireless Ethernet MCS mode 11ng
          status: associated
          nd6 options=29<PERFORMNUD,IFDISABLED,AUTO_LINKLOCAL>
From another connect machine in the same subnet:
Code:
$ ping X.X.X.251
PING X.X.X.251 (X.X.X.251): 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
 
OP
OP
dave

dave

Well-Known Member

Reaction score: 24
Messages: 415

Should I be submitting a bug to the 11 team?
 
OP
OP
dave

dave

Well-Known Member

Reaction score: 24
Messages: 415

Also, getting this in /var/log/messages:

Code:
Aug 31 00:55:30 rpi2 kernel: ifa_maintain_loopback_route: deletion failed for interface wlan0: 3
Aug 31 00:55:30 rpi2 kernel: ifa_maintain_loopback_route: insertion failed for interface wlan0: 17
Aug 31 00:55:50 rpi2 kernel: wlan0: link state changed to UP
Aug 30 17:55:51 rpi2 dhclient[3777]: send_packet: No buffer space available
Aug 31 00:56:27 rpi2 kernel: wlan0: link state changed to DOWN
Aug 30 17:56:29 rpi2 dhclient[3777]: send_packet: Network is down
Aug 31 00:56:29 rpi2 kernel: wlan0: link state changed to UP
Aug 30 17:56:29 rpi2 dhclient[3777]: send_packet: No buffer space available
Aug 30 17:56:29 rpi2 dhclient[3777]: send_packet: No buffer space available
Aug 30 17:56:56 rpi2 dhclient[3777]: connection closed
Aug 30 17:56:56 rpi2 dhclient[3777]: exiting.
Aug 30 17:56:56 rpi2 root: /etc/rc.d/dhclient: WARNING: failed to start dhclient
Aug 30 17:57:07 rpi2 dhclient[3962]: dhclient already running, pid: 3932.
Aug 30 17:57:07 rpi2 dhclient[3962]: exiting.
 

Rosendoktor

New Member


Messages: 6

Hello dave,

I'm having exactly the same problem with a urtwn(4) usb device, after upgrading from 10.3 to 11.0-RELEASE. The usb wifi worked fine in 10.3, but with 11.0-RELEASE the interface never gets a v4 address via dhcp. Also, no DHCP packets on the router's side (tested locally with tcpdump).

Reverted back to 10.3, and the wifi works again.
 

dch

Active Member

Reaction score: 42
Messages: 111

adrian@ on irc has given me a few tips, but it has been problematic here too. Disabling ht has fixed the DHCP issue for me:

Code:
ifconfig wlan0 -ht
I have also enabled in /boot/loader.conf
Code:
# edimax wifi
legal.realtek.license_ack=1
hw.usb.urtwn.enable_11n=1
Resulting in:

Code:
wlan0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
   ether 74:da:38:7e:e6:e0
   inet6 fe80::76da:38ff:fe7e:e6e0%wlan0 prefixlen 64 scopeid 0x2
   inet 172.16.2.15 netmask 0xffffff00 broadcast 172.16.2.255
   nd6 options=23<PERFORMNUD,ACCEPT_RTADV,AUTO_LINKLOCAL>
   media: IEEE 802.11 Wireless Ethernet OFDM/54Mbps mode 11g
   status: associated
   ssid skunkwerks channel 6 (2437 MHz 11g) bssid 80:2a:a8:5a:bd:3f
   regdomain FCC country US authmode WPA2/802.11i privacy ON
   deftxkey UNDEF AES-CCM 2:128-bit txpower 30 bmiss 7 scanvalid 60
   protmode CTS wme roaming MANUAL
   groups: wlan
full logs in my gist; https://gist.github.com/dch/25079d4b7e91beb2d2e7a5f2359b6d04
 
OP
OP
dave

dave

Well-Known Member

Reaction score: 24
Messages: 415

I did not have this problem with FreeBSD 11.0-RELEASE-p1 on an RPI-B-r2. I have not had a chance to test with my RPI-2 yet.
 

dch

Active Member

Reaction score: 42
Messages: 111


ifconfig wlan0 -ht


sadly -ht was not enough - sometimes this works, other times not.
 
Top