Solved FreeBSD 11 install on SSD failed mount during install

I was given an SSD drive (SanDisk SD6SB1M-128G-1006 X231706) so I decided to try and install FreeBSD 11 on it. I download the usb image.

During install at the point after choosing the Partitioning Scheme I get the following error dialog:

Failed to mount filesystem

An installation step has been aborted.  Would you like to restart the installation or exit the installer.

From there I can restart the installer or exit.

I have tried installing multiple times, I have tried the GPT, MBR and BSD label Partition scheme no matter what I get this error next.

One time I dropped into the shell and was able to format the drive using fdisk and newfs, exiting out of the shell I was stuck again.

Any suggestions? I couldn't find anything about this SSD not working with FreeBSD.
Just to update this....once using gpart as SirDice suggested, I was able to drop into the shell and then create the partition scheme manually. I then mounted the disk manually and created an fstab file, as the instruction when you drop into the shell at the Partitioning Scheme dialog say. Once I exited the shell...everything installed correctly and I'm using FreeBSD 11 now.