FreeBSD 11.1 reboot issues on Dell Latitude E7470 (1.17.5 BIOS)

Hi everyone,

I am having a little difficulty with my Dell ultrabook with FreeBSD 11.1: When I boot, either from the FreeBSD USB image, or from FreeBSD installed on the hard disc, everything works fine until I ask FreeBSD to reboot the machine. The system reboots, and I cannot use the keyboard to select an alternative boot device before the machine boots from the default boot device, because keypresses are not recognised at the BIOS screen. However, as soon as one gets to the FreeBSD boot menu, when it loads, the keyboard works again!

Windows 7, 10 and Ubuntu Linux (16.04 LTS) do not have this problem, but FreeBSD 11.1 does. Because this problem really manifests itself during execution of the BIOS - and not FreeBSD - I have asked Dell to consider looking at the BIOS, to ensure that the keyboard hardware is correctly reset on warm boots, but their response was unfortunately that FreeBSD is not a supported operating system, and they are therefore not likely to take any action to fix this - ProSupport contract or not.

Is there any chance that someone with similar hardware and firmware can replicate this problem on their end, and perhaps figure out why FreeBSD locks up the keyboard upon reboot? Any assistance would be really appreciated.
There's usually an option to enable "Legacy" support for keyboards/mice in the BIOS/UEFI. This basically emulates an old PS/2 connection for USB keyboards and mice. You can try switching that on or off. Sometimes it helps, sometimes not.

I'm also wondering if you get this issue if you use an external (USB) keyboard. It might be something specific to the laptop's own keyboard.
Thanks, I did add an external keyboard, but that exhibited the same behaviour.

I have a small update: I actually found that I needed to keep pressing F12 after FreeBSD reboots, but eventually there is a very small window, just before the BIOS screen disappears, where if you're holding down the key, it will respond. But that's not normal behaviour: For Windows and Linux reboots, you only have to press the key once, after the Dell logo appears, and it will bring up a piece of text at the top right of the screen, saying that it's preparing a multi-boot menu.

I will also try the legacy keyboard support, but that is something I would prefer to keep off, if possible: This system is fairly new (Skylake architecture, with Iris graphics), and FreeBSD - when booted - actually works really well on it. :)

Many thanks for your quick advice, however. I would still be interested to know why there is a difference in reboot behaviour, regarding the keyboard on the BIOS screen, versus Windows (and, especially, Linux) on this machine.
are you sure it's freeBSD and not Xorg that's "moded" you (usb) keyboard?

you might try running something in your /etc/rc.shutdown that re-initializes your keyboard to normal (usa/default) mode, it might like that. if that doesn't work i might look into insuring usb support is unloaded or reset, before reboot.