Solved FreeBSD 11.1 code19 at boot

I have new installation of FreeBSD 11.1 on amd64 platform.

I used FreeBSD-11.1-RELEASE-amd64-mini-memstick.img. SHA256 is fine.

however, boot fails with some what this error, and enters into mountroot> :

mounting from ufs:/dev/ada0p2 failded with error code 19

I tried allso tried but same boot error appears still.
set debug.acpi.dsabled="hostres"
Hard disk I installed FreeBSD used to have Xubuntu gnu/linux. I have feeling that this problem might be releated to some linux booting stuff on hard drive but not sure. I used guided partitioning at installationg and GPT.

Anyway, any suggestions how do I fix the problem?

ps. I'm pretty new to FreeBSD, but have FreeBSD installed on my second PIII computer. And now I am probably changing my main os to FreeBSD.
Are you sure it's /dev/ada0p2?
FreeBSD usually operates with slices (s), not partitions (p).
It could be /dev/ada0s1a, for example.
You can show the available mounts by typing "?" at the mountroot prompt.
Try all the mounts to see if you can boot.

Then you can use vi or ee and fixup /etc/fstab which is usually the culprit.
I found this on the handbook:

17.4. USB Storage Devices
Contributed by Marc Fonvieille.
Many external storage solutions, such as hard drives, USB thumbdrives, and CD and DVD burners, use the Universal Serial Bus (USB). FreeBSD provides support for USB 1.x, 2.0, and 3.0 devices.

USB 3.0 support is not compatible with some hardware, including Haswell (Lynx point) chipsets. If FreeBSD boots with a failed with error 19 message, disable xHCI/USB3 in the system BIOS.
The problem was that I thought I had tried all mounts at mountroot, but I somehow missed second hard disk - where FreeBSD is located.
So mounting /dev/ada1p2 turned everything to work.