Solved FreeBSD 10 does not boot - KVM - Kernel Trap 12

trivix

New Member


Messages: 2

Hello community,

I have a problem with FreeBSD 10.0-RELEASE AMD64. The image was downloaded from freebsd.org and is not optimized.

After I boot into multi-user mode I get the following massage:
Code:
kernel trap 12 with interrupts disabled


My hardware is a KVM virtualization enviroment. The CPU is an AMD Opteron 6274.



I have enabled and disabled virtio for network card and hard drive. The CPU is not emulated. But both times it doesn't boot. Disabling ACPI does not work either.

Does anyone know about this error and how to get FreeBSD working?

Greetings
Philipp


--SOLVED--
Two solutions are available:

1. Upgrading to CentOS7
2. KVM parameter -cpu Opteron_G3
 
Last edited:

VladStar

New Member


Messages: 1

I had a similar problem, when I tried to install FreeBSD 10 under CentOS 6.5 KVM. I didn't get a trap, but FreeBSD installation would hang right after the countdown (after the "Booting..." line).
The issue was fixed by upgrading the Linux kernel from 2.6.32-431.el6.x86_64 to 2.6.32-431.23.3.el6.x86_64 (the most recent version, available from yum updates repository).

Hope, this may help you as well.
 
OP
OP
T

trivix

New Member


Messages: 2

Sorry for writing back so late.

The parameter -cpu Opteron_G3 solved my issue!
I have a second host at a different location running CentOS7. No problems here. (exactly what VladStar said)

Thank you two!
 

junovitch@

Daemon
Developer

Reaction score: 620
Messages: 1,773

Better late than never. Feel free to edit your original post and mark it as solved to make it easier for the next person looking for the same answer. Totally relevant XKCD: http://xkcd.com/979/
 

Xzier

New Member


Messages: 1

I had this problem when trying to install pfSense on CentOS KVM on ProfitBricks IaaS cloud.

Tech support helped with details on how to get the install to boot correctly.

Immediately after booting press "Esc" to avoid auto boot and running into Kernel Trap 12.
Press "3" to load prompt and enter:
set hw.use_xsave="0" and enter boot afterwards to boot and install as expected.

It is not hard-coded so you have to do this every time the system is booting until you added it to the loader.conf:
echo "hw.use_xsave=0" >> /boot/loader.conf
 
Top