FreeBSD 10.3 installation bootloader failure on HP 8440p

I have an HP Elitebook 8440p laptop (Intel core-i5) which of course has MS-Windog 7 (ugh) on it, and I've been successfully running LINUX (Mageia 5) on it as well, dual boot, for some time. Never had a single problem. Well, except that I still need Windog from time to time :)

Many years ago, I tried one of the *BSDs and found it interesting, but had no compelling reason to switch from my favourite Mandrake/Mandriva/Mageia LINUX. I've done a lot of LINUX since then. I've recently heard some buzz about FreeBSD and want to try it again. Diversity is good; it might even address some of the annoying little things that I've come to grumble about, but accept, over the years.

I have lots of experience in downloading & burning DVDs & CDs, and I check SHA256 sums. I've been doing embedded electronics & software for some 35 yrs, and running *NIXes for over 30 yrs, lots of variants. I've seen a lot, although of course, not everything.

So, I downloaded the following and burned them to their respective CD & DVD media:
  • FreeBSD 10.3 AMD64 DVD-1 image
  • FreeBSD 10.3 AMD64 boot-only CD image
  • FreeBSD 10.3 AMD64 UEFI boot-only CD image (just on the off chance that the BIOS was lying to me)
  • FreeBSD 10.3 i386 boot-only CD image (just in case there's something wonky about the processor - surely a 386 image would boot)
  • FreeBSD 9.3 AMD64 boot-only CD image (older bootloader? no appears to be the same)
They all do the same thing:
CD Loader 1.2

Building the boot loader arguments
Looking up /BOOT/LOADER... Found
Relocating the loader and the BTX
Starting the BTX loader

BTX loader 1.00  BTX version is 1.02

--herein is some kind of frame dump, can take pic & provide if needed--
BTX halted

I can't promise you that the frame dump is the same, but the rest is identical. All architectures, both CD & DVD media.

As mentioned, there has been no hiccup at all in the hardware otherwise, including optical drive, hard drive, processor, memory etc.

This does sound reminiscent of Thread 21649, although the messages were different; perhaps that would be due to the age of the posting (2011). That one wasn't satisfactorily resolved, it appears. I didn't find others.

Any ideas as to where to start?
Oh, should also add that I deleted the LINUX partitions, thinking that maybe the kernel was off trying to use its swap space (I know, I know, kind of far fetched but not impossible). All I succeeded in doing was bork the Mageia bootloader, ha ha. No difference. Now fixed the bootloader problem by putting back on a minimal Mageia installation. Lots of free space available.
Are you booting in UEFI or legacy mode? Does the HP have the latest system firmware? Have you tried a USB image? (Note that these are not the same as the CD images.)
UEFI is turned off, or so the BIOS says. I've never tried with it turned on. Afraid to, actually - might be a one way trip, ha ha. As mentioned, Mageia 5 loaded up with no problem - just now had to reinstall it because had blown it away as part of debugging (make sure lots of empty disk space) and system refused to boot because the 2nd stage bootloader was on the deleted partition, oops. But it's back now booting Mageia, and still no joy on the FreeBSD loader.

I can't say whether the latest system firmware is on it, but I will check when I get a chance.

I have not tried USB yet. I wasn't aware that they are different, but it does make sense that it would be. I'll dig for an old USB flash drive around here and give that a whirl.

It might take a couple of days to get around to checking these items. I really do want to try out FreeBSD!
PC-BSD uses Grub, or at least used to, and might boot on a system that does not like the stock FreeBSD bootcode.
Now I am getting somewhere. I did a quick Google search of "freebsd hp elitebook 8440p" - why didn't I think of that before? Anyway, came up with Thread 15400 and , both advising that the key is to change the SATA controller from AHCI to IDE compatible in the BIOS. The latter reference also says to use UEFI media even if UEFI is turned off, so that's what I'm doing. Now progressing! Shall see how it goes from here, will make further notes later.
OK now it seems to load up, even connects to Internet over WiFi, gets updates, seems very happy. But, when it reboots, it hangs with GRUB error 22 - disk partition missing? I've tried multiple times, with different media - boot-only CD which downloads packages, and all-in-one DVD.

Sigh. There is an MS-Windog partition on this machine which I'm trying to preserve for those times when I really want to get frustrated ;)

Each time, I got my system back up by the brute force approach - put Mageia 5 back on it, which re-installed GRUB and set things up again.

I have another 750GB HDD which I've cleared off. I will put it in the machine and give the whole disk to FreeBSD. Then I'll get it going completely, I'm sure.

More to follow.