FreeBSD 10->11: How can I change the WiFi interface mac address?

eldaemon

New Member


Messages: 6

Hi everyone,

I upgraded to FreeBSD 11 yesterday. Seems like you can't manage interface settings with ifconfig anymore.

For instance, I used to do this:

Code:
ifconfig ath0 ether ff:ff:ff:...
ifconfig wlan0 create wlandev ath0
Now, I can't do anything to ath0. If I set the mac address on wlan0, it doesn't work.

This seems to have changed here: https://lists.freebsd.org/pipermail/freebsd-current/2015-August/056956.html

How can I change the mac address for ath0 now?

Thanks!
 

tobik@

Daemon
Developer

Reaction score: 1,361
Messages: 1,909

Works as expected for me (though with bwn(4)).
Code:
ifconfig wlan0 create wlandev bwn0
ifconfig wlan0 ether ff:ff:ff:...
 

ljboiler

Well-Known Member

Reaction score: 96
Messages: 325

I had the same problem after updating to FreeBSD 11 with what used to work for setting up a lagg interface to auto-switch between wired (msk) and wireless (ath) on my laptop.

I solved it in my case by setting the mac address of the wired interface to that of the wireless one, rather than the other way around.
 

`Orum

Active Member

Reaction score: 14
Messages: 123

Works as expected for me (though with bwn(4)).
Code:
ifconfig wlan0 create wlandev bwn0
ifconfig wlan0 ether ff:ff:ff:...
Hrm, you're setting this on the wlan interface instead of the parent (bwn0) as eldaemon was, so I wonder if that's why it worked for you and not him (though he said setting it on wlan0 had no effect).

Either way I'm curious to know as I have more than a few machines in this situation.
 
Top