Framebuffer question.

rewtkid

Member

Reaction score: 8
Messages: 68

I wasnt sure where to put this. Feel free to move it. I am running FreeBSD 12-RELEASE, on an UEFI system and using the nvidia-driver port. It is enabled and X is using it fine. My question is when its booting, my console is using VT, and it says efi too if i remember right but its stuck at 1024x768. My videocard is an nvidia gtx 750TI surely i can get a better mode than that? I tried the different modes there is three of them in the bootloader but i cant seem to get the resolution i want to stick. Gop gives an error even though i am on uefi. I dont understand why I should be able to use it right? Does nvidia have a framebuffer/KMS I can switch the console to use, and if so how? Thank you so much. My system is almost perfect but I would like a better console. I am using nvidia-modeset kld_list="nvidia-modeset" in rc.conf too if that should be noted.
 
OP
rewtkid

rewtkid

Member

Reaction score: 8
Messages: 68

This is my current loader.conf

Code:
kern.vty=vt
kern.vt.fb.default_mode="1280x1024"

If in the bootloader I set mode 3 it boots 1280x1024 fine. Id actually prefer 1920x1080 (native but its not listed for some reason.) but even with those in loader.conf, I still only seem to be getting 1024x768 at boot unless i manually set the mode. Is there an nvidia framebuffer kms I can use? How do i set it permanently. I read the vt manpage.
My rc.conf

Code:
     kld_list="nvidia-modeset"
 
OP
rewtkid

rewtkid

Member

Reaction score: 8
Messages: 68

After doing research this is now my loader.conf. I am not sure why i didnt need nvidia and nvidia-modeset in there before and it just worked. X that is. I guess what was in rc.conf was enough. But this howto says to put it in loader.conf as well. Anyway dont get me wrong my problem isnt solved im still only getting 1024x768 in console. Forgive me for being oblivious to this stuff I find it all quite confusing.

Code:
      kern.vty=vt
      efi_max_resolution="1920x1080"
      kern.vt.fb.default_mode="1920x1080"
      nvidia_load="YES"
     nvidia-modeset_load="YES"
    
(23:34 mike@bsd ~) >
 

VladiBG

Daemon

Reaction score: 582
Messages: 1,258

In the UEFI there's graphical output protocol driver (GOP) which control the resolution. This driver is part of the UEFI/BIOS in your motherboard and can be update only by upgrading your BIOS/UEFI. Go to the website of your computer manufacture and check the changelog of your BIOS if there's some fixes regarding the GOP driver then you can download the new motherboard BIOS and update it.
 
OP
rewtkid

rewtkid

Member

Reaction score: 8
Messages: 68

In the UEFI there's graphical output protocol driver (GOP) which control the resolution. This driver is part of the UEFI/BIOS in your motherboard and can be update only by upgrading your BIOS/UEFI. Go to the website of your computer manufacture and check the changelog of your BIOS if there's some fixes regarding the GOP driver then you can download the new motherboard BIOS and update it.

Yes I figured that out in the last 30 minutes. I can do it manually via loader but if i put gop set 2 in loader.conf and / or loader.conf.local i get no joy. I dont understand why the highest i can go is 1280x1024 when my native is 1920x1080 either. Either way it refuses to do it automatically when i edit those configs. I will update the bios tomorrow its late here. Thank you.
 

VladiBG

Daemon

Reaction score: 582
Messages: 1,258

On some high resolution screens the default console/terminal resolution is lower by default so the setup utilities that doesn't support dpi scaling can render a bigger screen fonts. For example if you run MDT deployment on UHD display the fonts will be very very small and hard to read that's why some manufactures set the default screen resolution lower than the native display. Some older laptops for example has incorrect or missing default resolution by the GOP driver which can lead to unreadable screen like this one
keymF2h.jpg
 
OP
rewtkid

rewtkid

Member

Reaction score: 8
Messages: 68

Thanks guys. I updated my bios. the board is an asus x99/1 usb 3.1. It was only a security update but i took a picture of my overclock settings, actually all settings like which disks were raid etc, hell if id remember without a picture and flashed it anyway. No change. I guess I will just stick with 1280x1024 when i need it ill do it manually and 1024x768 regularly that will have to be fine for now we all wasted enough time on this. I know I did. Thank you.
 

tedbell

Active Member

Reaction score: 122
Messages: 240

Try removing this line:
Code:
 kern.vt.fb.default_mode="1920x1080"

and removing the nvidia lines.
Then add these to your rc.conf

Code:
# for the stock -RELEASE kernel:
kld_list="nvidia nvidia-modeset"
nvidia_name="nvidia"
nvidia_modeset_name="nvidia-modeset"
 
Top