Framebuffer error on startx command (solved)

Installed freebsd 13 from the memstick img, pkg installed xorg following Instructions then installed xfce, startx command returns errors :

EE can not run in framebuffer mode. Please specify busIDs for all framebuffer devices. EE connection terminated with error (1)

Please help.
 
Thank you. I tried, I reinstalled the O/S, I went through the steps, the amd information that matches graphic cards to machine readable names (such as amdgpu or radeonkms) did not have information for the CPU model Radeon 3200G with its "Radeon Vega" graphics. I tried various combinations in the rc.conf file, it didn't work. ( Before this I tried to install from the iso image copied by dd to an usb, the installation did not proceed )
 
I remember having this message when trying out Gnome on FreeBSD a while ago.
Two things to try:
  • Turn on/off the dual graphics card option in BIOS (named Optimus on my machine).
  • Reinstall FreeBSD in legacy BIOS mode, or try with UEFI if you were using legacy BIOS.
 
C++:
freebsd-version -kru ; uname -aKU
13.0- RELEASE #0 releng/13.0-n244733-ea3labc261f: Apr 9 ... amd64 1300139 1300139 (typed, not copied and pasted)

Edited rc.conf to delete path to leave it as

C++:
kld_list=amdgpu

Could get to xfce as root after reboot. Will add user to wheel etc to try and resolve privileges.

Thank you.
 
Top