Forum display on Firefox

Hokie

New Member


Messages: 2

Freebsd 11.2, Xorg, Fluxbox, Firefox.

When I go to the forum using my desktop computer, the top and bottom banners stretch across the entire screen but all content in the middle of the screen, such as posts and my profile, is compressed into a narrow column on the right side of the screen.

I'm using the noscript plugin, but when I "allow all on this page" there is no change.

The freebsd forum is the only site I use that has this problem. I also use some other forums without any problem. I'm posting this from my phone because of the problem on the desktop.

Any ideas about how to fix this?
 

johnblue

Well-Known Member

Reaction score: 40
Messages: 309

Hokie, I too use Firefox with noscript plus requestpolicy and it is indicating that two more domains are being used:

1547166387526.png


I would recommend that you review your noscript setting to make sure that bootstrapcdn.com and jquery.com are being allowed.
 

Trihexagonal

Daemon

Reaction score: 847
Messages: 1,465

I'm using www/firefox-esr on some machines and www/firefox on others but use NoScript and uBlock Origin together on them all. I only allow scripting for freebsd.org and everything works fine for me as far as basic functionality and text display with both versions of Firefox.

forum01.png

Some of the icons don't display as they should with this config and I may need to adjust accordingly to get functionality.
 

ILUXA

Aspiring Daemon

Reaction score: 429
Messages: 666


To show paranoid forum header (dickbar), that follows your everywhere, always on top of every page,
and to hide number of entered symbols in the bottom right corner of reply form,
that's overlapping entered text, I'm using
Code:
@-moz-document domain('forums.freebsd.org') {
/* fixed position for dickbar */
	.p-navSticky { position: absolute !important; width: 100% !important; }
/* hide dickbar shadows */
	.p-navSticky.is-sticky { box-shadow: unset !important; }
/* little margin on top is required after dickbar elimination */
	.p-body { margin-top: 50px; }
/* hide symbol counter in reply form */
	.fr-counter { display: none; }
}
in ~/.mozilla/firefox/<your_profile_dir>/chrome/userContent.css (create if it doesn't exist).
(Or ~/.moonchild\ productions/pale\ moon/<your_profile_dir>/chrome/userContent.css if you're using palemoon.)
screenshot100.png

To remove forum dickbar from chromium, install user css extension, then with opened forums.freebsd
press extension icon, toggle it to "on" and add css code from above.
 
Last edited:

Minbari

Well-Known Member

Reaction score: 174
Messages: 339

Any ideas about how to fix this?
Reset Firefox with add-ons disabled and after that step reinstall your favorite add-ons. I'm also using noscript, uBlock Origin, uMatrix and many others and I don't have any problem.

ff01.png ff02.png
 
OP
OP
H

Hokie

New Member


Messages: 2

Update: If I go to the bottom of the screen where the style chooser is located and select the BlueFreeBSD style, I get a normal display. All other styles result in the original problem.
 

Trihexagonal

Daemon

Reaction score: 847
Messages: 1,465

I'm using www/firefox on the T400 I use most for desktop and yesterday got a screen that was not properly rendered different than shown with 2 columns of posts. I refreshed the page but still the same. I was able to go back to the index page and everything has rendered correctly since.

It just crashes when closing tabs every time I'm composing a post it's close to what I'm thinking Junk software. I have better luck with ESR on other machines but liking it less since it had to have the new Quantum Engine too.

Just what is the Quantum aspect of it exactly? That they don't quite have everything figured out yet?

I have www/palemoon on each laptop and if I'm going to be typing an extended period use it because it only crashed a tab once in recent memory with the same goofy page FiddleFox shows.

I would gladly use Monkey if not for the fact it's had vulnerabilities listed the better part of a year. I finally uninstalled it and wait with baited breath for the day they quit monkeying around and fix it.

I only use Mozilla based browsers mostly because of the extension I can't live without but I'm to the point I can live without the frustration it puts me though crashing like it has since they made it Quantum Quackery.

I am sorely disappointed in what it was when I began using compared it to what it has become.
 

rsronin

Member

Reaction score: 75
Messages: 91

Kind of same issue, but only yesterday in one particular thread.
 

RedPhoenix

Active Member

Reaction score: 27
Messages: 155


To show paranoid forum header (dickbar), that follows your everywhere, always on top of every page,
and to hide number of entered symbols in the bottom right corner of reply form,
that's overlapping entered text, I'm using
Code:
@-moz-document domain('forums.freebsd.org') {
/* fixed position for dickbar */
    .p-navSticky { position: absolute !important; width: 100% !important; }
/* hide dickbar shadows */
    .p-navSticky.is-sticky { box-shadow: unset !important; }
/* little margin on top is required after dickbar elimination */
    .p-body { margin-top: 50px; }
/* hide symbol counter in reply form */
    .fr-counter { display: none; }
}
in ~/.mozilla/firefox/<your_profile_dir>/chrome/userContent.css (create if it doesn't exist).
(Or ~/.moonchild\ productions/pale\ moon/<your_profile_dir>/chrome/userContent.css if you're using palemoon.)
View attachment 5872

To remove forum dickbar from chromium, install user css extension, then with opened forums.freebsd
press extension icon, toggle it to "on" and add css code from above.
What... The?
 
Top