Focusrite Scarlett Solo no sound

fijidrummerboii13578

New Member


Messages: 2

Hello all,

I finally got around to playing with FreeBSD, and it works like a charm! Except, one thing is driving me nuts.

I am migrating from Linux, and there I used my Focusrite Scarlett Solo audio interface for all my audio I/O, and on Linux it was basically plug n' play. I expected more or less the same from FreeBSD, but oddly enough I ran into a strange problem

I cannot get any sound out of my interface to play. When I go to GNOME Settings and try to set the volumes, none of the tests work and no sound comes out. I can't play audio files; no sound comes out anywhere. I tried to run cat /dev/sndstat and all that came out was this:

Code:
pcm0: <Realtek ALC269 (Analog)> (play/rec) default
pcm1: <Realtek ALC269 (Analog 2.0+HP/2.0)> (play/rec)
pcm2: <USB audio> (play/rec)
No devices installed from userspace.
That last bit confused me; I thought PulseAudio would suffice? What drivers would I need? I already tried loading the kernel module uaudio, but are there any other possibilities?

The peculiarity was that I was able to run cat /dev/random > /dev/dsp2.0 and that made static go through to the headphones I use that are connected to the audio interface. I was able to control its volume with the volume knob on the audio interface itself, but not from the GNOME Settings panel. My microphone direct monitor works, and I can adjust the gain. However, I cannot get any audio through to the interface from the computer except for the static that came through running that command. How do I configure my audio interface to play audio in FreeBSD?

I'm running 12.1-RELEASE and a GENERIC kernel on an i386 Dell Optiplex 380, if that matters.
 
Top