"Fn" key not recognized to change the screen brightness on Dell laptop.

Hi,

My laptop is a dell latitude 7240 with a Haswell cpu.

Mate Desktop is installed.

My goal is to get the “fn” working to change the screen brightness.

I installed https://www.freshports.org/graphics/intel-backlight and I can change the screen brightness by entering ,for.e.g, “intel_backlight=40”.

It works as well by doing “ hw.acpi.video.lcd0.brightness=40”.

I followed the instructions in this post http://www.daemonology.net/blog/2020-05-22-my-new-FreeBSD-laptop-Dell-7390.html where the author said:

“I want to be able to control the brightness of the screen (aka. the backlight connected to the Intel video chipset):

# pkg install intel-backlight

and in particular to be able to control it via the function keys (Fn+Up, Fn+Down) which Dell exposes via ACPI:

# echo 'acpi_video_load="YES"' >> /boot/loader.conf

# cp /usr/local/share/examples/intel-backlight/acpi-video-intel-backlight.conf \

/usr/local/etc/devd/


The keys associated for the screen brightness are the “Fn” and the top arrow to increase the brightness and the down arrow to decrease.

The problem is when I press the “fn” key with one of those keys, nothing happens but I can see the screen very slightly flashing but there is no light increased or decreased.

Please note the “fn” key is working fine if I want to change the keyboard backlight by pressing “fn” and the right arrow .


How can I use the “fn” key to modify the screen brightness ?


Thank you for your help.
 
I had to sysrc kld_list+=" acpi_ibm" for the screen brightness to be adjustable via the Fn keys on my ThinkPad laptop. Unfortunately, there is no acpi_dell(4)... Please consider to file in a bug report @Dell: "Please publicly document the I/O ports & relevant ACPI interface stuff to enable open source OSs to access the Fn keys of your laptops". Hint: crawl the Weltnetz for L*x stuff on Dell ACPI laptop stuff. Maybe they figured that out, and it can be ported to FreeBSD.
 
Thank you Mjölnir.
I tried to open a bug with Dell but apparently, this has to be done through a service request.
And when I logged to my Dell account, I got the following message:
"Your product is out of warranty.
Service requests are not available for this product.Please use a different contact option"

I contacted them through Tweeter.I don't have that much hope but let's see what will happen :)
I spent a few hours looking for a solution and most of the time ,the possible answers came from the Arch forum.
I tried a few things that could have been helped to sort this out like with showkey xbinkeys xmodmap xbacklight but it was unsuccessful ...
The link I posted in my previous let me think it was possible as the author ( Colin Percival) was able to use his "Fn" keys from a Dell laptop.
I keep searching and will post if I find something that could help.
 
Consider to also write an e-mail to the mailing list (you have to subscribe 1st) e.g. <freebsd-desktop> or contact <cp@> directly, maybe he can point you in the right direction.
 
They're changing the ACPI BIOS interface with every new model... This whole PC stuff keeps scratching my nerves for decades now... ;) And that new ARM stuff is even worse, no standards @all...
 
Top