Solved [Fluxbox] Question about syntax in ~/.fluxbox/menu – Launch a terminal which remains opened afterwards

Wilou

New Member


Messages: 3

Hello,

First post on the forum. :)

I have installed FreeBSD (12.2-RELEASE) on my Thinkpad X200 and everything works fine. Not much left to do to have the system I want (the big remaining thing is to configure Samba, the rest is little details).

Among these details, there's a thing I have a problem with, according to the title of this topic: the syntax in the menu file for Fluxbox.
I have installed sysinfo and I want to launch it from the menu (my terminal is lxterminal). So I write:

[EXEC] (sysinfo) {lxterminal -T "sysinfo" -e sysinfo -a}

Everything is fine, I see the terminal, the infos which appear in it, but in the end, the terminal closes itself.
What should I write in my code to keep lxterminal opened on my screen ?

The same thing happens with another application, Lynis. The syntax is pretty similar:

[EXEC] (Lynis) {lxterminal -T "Lynis" -e lynis audit system}

I've tried another terminal (xterm), and I have the same behavior. So, I think it's not related to the terminal, but I can be wrong. I have the same problem on Debian Buster.

Probably a simple thing, but I don't find how to do that.

Do you have an idea ?

Thank you ! :)

W.
 

Trihexagonal

Son of Beastie

Reaction score: 2,083
Messages: 2,644

This is the Fluxbox menu syntax for opening a program in an xterm terminal:

Code:
 [exec]   (vi) {xterm -e vi}

If I need to open a program as root I su to become root and open the program by commnd to work as root from that terminal. When I'm finished I log out to my usr account.
 
OP
Wilou

Wilou

New Member


Messages: 3

Hello,

Thanks for your answer. :) This part of the syntax isn't what's causing me trouble. The thing is everything launches fine (as root or not). It's when the command has finished that I would like to keep the terminal opened, but it closes everytime. On the contrary, not a problem with top or htop for example (the syntax is the same, and it's already in the menu when Fluxbox is executed the first time).

Sorry, english is not my native language, perhaps I don't explain well.

W.
 
OP
Wilou

Wilou

New Member


Messages: 3

Hello again,

I think that's good !
I tried for sysinfo and then for Lynis with these commands:

Code:
[EXEC] (sysinfo) {lxterminal -T "sysinfo" -e sh -c 'sysinfo -a; sh'}
[EXEC] (Lynis) {lxterminal -T "Lynis" -e sh -c 'lynis audit system; sh'}

The terminal doesn't close anymore, I simply have the prompt and I can navigate to read what's written above.

:cool::)

W.
 
Top