[Fluxbox] numerical keypad in Fluxbox

everypot

Active Member

Reaction score: 8
Messages: 202

The numerical keypad doesn't work under fluxbox. It works with KDE(of course). So I assume it's fluxbox's problem. Any suggestion?
 

MarcoB

Well-Known Member

Reaction score: 123
Messages: 403

I'm having this too. In my case the numlock is set in the BIOS to on after booting. In the console the led is on, and keypad works. But in X (fluxbox) the led is still on but the keypad doesn't work anymore. After pressing the numlock key a few times the numkeys work again.
 

graudeejs

Son of Beastie

Reaction score: 707
Messages: 4,617

To solve this you need to install x11/numlockx
and add it you your VM config, so it's run every time you start your window manager.

I'm not 100% sure, but it might as well work if you add it to ~/.xinitrc, or ~/.xsession, depending how you start X (on my system, one is link to another).



P.S. now you both can thank me for this :D
 
OP
E

everypot

Active Member

Reaction score: 8
Messages: 202

killasmurf86 said:
To solve this you need to install x11/numlockx
and add it you your VM config, so it's run every time you start your window manager.

I'm not 100% sure, but it might as well work if you add it to ~/.xinitrc, or ~/.xsession, depending how you start X (on my system, one is link to another).



P.S. now you both can thank me for this :D

Thanks. I installed and run numlockx, and the number keypad works. I will try to add
numlockx on &

to .xinitrc before the line exec fluxbox

Need to test this after reboot(busy with other work, cannot do it now~).
 

MarcoB

Well-Known Member

Reaction score: 123
Messages: 403

killasmurf86 said:
To solve this you need to install x11/numlockx
and add it you your VM config, so it's run every time you start your window manager.

I'm not 100% sure, but it might as well work if you add it to ~/.xinitrc, or ~/.xsession, depending how you start X (on my system, one is link to another).



P.S. now you both can thank me for this :D

Thanks for the tip. Just executing it works fine. I'll put it in my .xinitrc.
 

expl

Aspiring Daemon

Reaction score: 126
Messages: 664

This is not fluxbox issue, X11 turns off keypad every start, just some desktop managers turn it back on (like your mentioned gnome). Been like this since I can remember (XFree86 times). Isn't a big problem, a _single_ Numlock press will bring it back (no need to hammer it).
 

graudeejs

Son of Beastie

Reaction score: 707
Messages: 4,617

expl said:
This is not fluxbox issue, X11 turns off keypad every start, just some desktop managers turn it back on (like your mentioned gnome). Been like this since I can remember (XFree86 times). Isn't a big problem, a _single_ Numlock press will bring it back (no need to hammer it).

really who the hell, figured numlock should be off by default :< single key press would turn it off
 

Beastie

Daemon

Reaction score: 548
Messages: 2,275

Well, even if we use the numpad, many people don't even know what it is for. Seriously!

In some BIOSs, like MarcoB's, there's an option (set on by default) to turn it on automatically, but in some there's no option or it is set off.

So since many people don't use the numpad or don't know what it is they disable it, especially that a LED turned on means more power consumption and this is baaaaaaaaaaaaad for the planet. LOL
 
Top