Solved fluxbox not opening apps

D

Deleted member 30996

Guest
Your menu must not be executing the commends: This is how mine looks:

Code:
[begin] (Fluxbox)
[encoding] {UTF-8}
      [exec]   (urxvt) {urxvt}
      [exec]   (Firefox) {firefox}
[submenu] (Files)
      [exec]   (xfe) {xfe}
      [exec]   (leafpad) {leafpad}
      [exec]   (vi) {xterm -e vi}
[end]
[submenu] (Multimedia)
      [exec]   (Gimp) {gimp}
      [exec]   (VLC) {vlc}
      [exec]   (Audacious) {audacious}
[end]
[submenu] (System)
      [exec]   (gKrellm) {gkrellm}
      [exec]   (Asunder) {asunder}
      [exec]   (ePDFview) {epdfview}
      [exec]   (xclock) {xclock}
      [exec]   (xcalc) {xcalc}
      [exec]   (xterm) {xterm}
      [exec]   (Reload .Xdefaults) {xrdb -load $HOME/.Xdefaults}
[end]
[submenu] (Fluxbox)
      [config] (Configure)
[submenu] (System Styles) {Choose a style...}
      [stylesdir] (/usr/local/share/fluxbox/styles)
[end]
[submenu] (User Styles) {Choose a style...}
      [stylesdir] (~/.fluxbox/styles)
[end]
      [workspaces] (Workspace List)
[submenu] (Tools)
      [exec] (Window name) {xprop WM_CLASS|cut -d \" -f 2|xmessage -file - -center}
[end]
[submenu] (Window Managers)
      [restart] (twm) {twm}
[end]
      [commanddialog] (Fluxbox Command)
      [reconfig] (Reload config)
      [restart] (Restart)
      [exec] (About) {(fluxbox -v; fluxbox -info | sed 1d) | xmessage -file - -center}
      [separator]
      [exit] (Exit)
[end]
[endencoding]
[end]
 
  • Thanks
Reactions: a6h
Your menu must not be executing the commends: This is how mine looks:

Code:
[begin] (Fluxbox)
[encoding] {UTF-8}
      [exec]   (urxvt) {urxvt}
      [exec]   (Firefox) {firefox}
[submenu] (Files)
      [exec]   (xfe) {xfe}
      [exec]   (leafpad) {leafpad}
      [exec]   (vi) {xterm -e vi}
[end]
[submenu] (Multimedia)
      [exec]   (Gimp) {gimp}
      [exec]   (VLC) {vlc}
      [exec]   (Audacious) {audacious}
[end]
[submenu] (System)
      [exec]   (gKrellm) {gkrellm}
      [exec]   (Asunder) {asunder}
      [exec]   (ePDFview) {epdfview}
      [exec]   (xclock) {xclock}
      [exec]   (xcalc) {xcalc}
      [exec]   (xterm) {xterm}
      [exec]   (Reload .Xdefaults) {xrdb -load $HOME/.Xdefaults}
[end]
[submenu] (Fluxbox)
      [config] (Configure)
[submenu] (System Styles) {Choose a style...}
      [stylesdir] (/usr/local/share/fluxbox/styles)
[end]
[submenu] (User Styles) {Choose a style...}
      [stylesdir] (~/.fluxbox/styles)
[end]
      [workspaces] (Workspace List)
[submenu] (Tools)
      [exec] (Window name) {xprop WM_CLASS|cut -d \" -f 2|xmessage -file - -center}
[end]
[submenu] (Window Managers)
      [restart] (twm) {twm}
[end]
      [commanddialog] (Fluxbox Command)
      [reconfig] (Reload config)
      [restart] (Restart)
      [exec] (About) {(fluxbox -v; fluxbox -info | sed 1d) | xmessage -file - -center}
      [separator]
      [exit] (Exit)
[end]
[endencoding]
[end]
where should i paste all of this?
 
D

Deleted member 30996

Guest
That is your fluxbox menu, it goes in the fluxbox directory:

/usr/home/username/.fluxbox

But you'll have to make hidden files/folders visible through your file manager. The period before it desiginates it as a hidden folder.
 
That is your fluxbox menu, it goes in the fluxbox directory:

/usr/home/username/.fluxbox

But you'll have to make hidden files/folders visible through your file manager. The period before it desiginates it as a hidden folder.
okay, but where should i paste all of that, in what file?
 
You should have a /usr/local/share/fluxbox directory, If you copy that over to $HOME/.fluxbox, you can then edit the menu and keybindings in that file. I think Trihexagonal has a whole tutorial here about setting up a desktop and I believe said tutorial uses fluxbox,
 
D

Deleted member 30996

Guest
Here's the link but editing the fluxbox menu isn't included in it. Just paste the part I provided into yours in the same place it begins.

 
Here's the link but editing the fluxbox menu isn't included in it. Just paste the part I provided into yours in the same place it begins.

i kinda did all of the steps already, is there any other fix?
 
D

Deleted member 30996

Guest
Have you edited the menu to include the programs you installed? No?

Run this command from your user accont to generate a menu with the programs you installed listed on it:

fluxbox-generate_menu
 

SirDice

Administrator
Staff member
Administrator
Moderator
That sounds like you're still on the default TWM window manager, not Fluxbox.
 
There will be a file named menu.
Please teach the user who asks you how to proceed to generate the menu, how to proceed to add direct links to the fluxbox monitor, how to create icons in the taskbar, how to generate the icons in the fluxbox menu, if possible, do it in a file and leave it here, so there will be users who want to learn and use fluxbox. The guide is very outdated from years long ago behind.
 
found out right now what i needed to do : every time i install an appi gotta open the menu file and add it over there for example : firefox didnt run the command firefox and it wasnt existing in the system so i replaced it with midori and command midori as to run it! :D
 
D

Deleted member 30996

Guest
I would gladly do it if I had idea.
You should know all about it by now, teo

I've told you how to add icons to the menu when you posted the question to my tutorial, including telling you how to add links to the menu when you don't even use Fluxbox and have answered every question you were too lazy to look up yourself and could possibly think of to use as an excuse to troll my tutorial for the past 4 years.

The guide is very outdated from years long ago behind.
Now you've taken up someone's bad habit of telling outright lies, teo, and are no better at it than they were.

I just updated it earlier today with that command and you can see by my posts every time I have updated it. The whole back page is full of updates I've made to it this year alone. The last question I answered before being offline for a year was yours about icons on the menu.


My site states it was updated May 19, 2021.


Don't do it again, teo. You don't want to end up on my desktop in the Box O' Stupid people.
 
Top