fix problems with marked as IGNORE packages

ccc

Aspiring Daemon

Reaction score: 13
Messages: 621

hi

I've done portupgrade -a on my freeBSD 7.0 and I'm getting this:
Code:
** Fix the problem and try again.
--->  Skipping 'net/tightvnc' (tightvnc-1.3.9_1) because a requisite package 'jdk-1.6.0.3p4_2' (java/jdk16) failed (specify -k to force)
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        - security/pecl-hash (marked as IGNORE)
        - devel/pecl-json (marked as IGNORE)
        - x11-drivers/xf86-video-vga (marked as IGNORE)
        - x11-drivers/xf86-video-via (marked as IGNORE)
        * x11-drivers/xorg-drivers (xorg-drivers-7.3_2)
        ! java/jdk16 (jdk-1.6.0.3p4_2)  (unknown build error)
        * net/tightvnc (tightvnc-1.3.9_1)
howto fix problems with marked as IGNORE packages ?
 

Djn

Well-Known Member

Reaction score: 67
Messages: 392

If you don't use them, the easiest is to just pkg_delete them (so they won't be updated), and probably do a make config in x11-drivers/xorg-drivers , to make sure it doesn't depend on the previous two.

If you do use them, the fastest solution is probably to throw money at the maintainer.
 
  • Thanks
Reactions: ccc
Top