Firefox shows distorted video with pink color

kpect

Member

Reaction score: 9
Messages: 68

Hello.
When I enable 'hardware acceleration' in Firefox's options I get pink haze on every video I watch in Firefox. (see screenshot - http://3.1m.yt/utNPwE.png) (original link:
)
Disabling that option fixes the video's color. That happens on Firefox-ESR 45.7.0
When I tried to use Firefox 51.1.0 even disabling hardware acceleration didn't help to fix the issue, moreover the video was jumping and twitching in a second time loop untill I drag the handle towards the new fragment where jumping and twitching continues.
So for now I can't even use Firefox 51.1.0 with Youtube on my laptop.

My hardware where I have issues:
Laptop - Lenovo T430 with Intel HD Graphics 4000
Desktop - Core 2 Quad + Radeon R5 230 'Caicos'
 

drhowarddrfine

Son of Beastie

Reaction score: 1,263
Messages: 3,304

I don't see the pink cast. YouTube uses HTML5 video by default now but, perhaps, you are seeing it in Flash? Flash has issues with this sort of thing.
 
OP
OP
K

kpect

Member

Reaction score: 9
Messages: 68

I don't see the pink cast. YouTube uses HTML5 video by default now but, perhaps, you are seeing it in Flash? Flash has issues with this sort of thing.
Nope, I also use HTML5 and every video file I open using Firefox [Ctrl+O] has this pink tint.
 
OP
OP
K

kpect

Member

Reaction score: 9
Messages: 68

I've found a reason:
layers.acceleration.force-enabled should be set 'false'
 

drhowarddrfine

Son of Beastie

Reaction score: 1,263
Messages: 3,304

This sounds familiar to me from years ago but I had set mine to true. When and why, I don't recall but, as I said, I don't have that problem.
 
A

ASX

Guest


This sounds familiar to me from years ago
Indeed, I can clearly remember about this issue from around 2011, on lInux.
At the time the problem seemed to be related to flashplayer coupled with some specific video driver, and the solution was to turn off the hw acceleration in flashplayer (not in firefox), that was: wait for the video to load, right click on the video and turn of hw acceleration.
I'm not using flash anymore, therefore I'm unsure if the fix still apply today.
 
Top