Firefox fonts jagged and ugly

i-bsd

Member

Thanks: 6
Messages: 55

#1
This topic really needs an up-to-date, comprehensive How-To.

Font rendering in Firefox is hideous. The webfonts pkg does not change it and every suggestion I've found does not work.

Chromium looks fine.

Can anyone advise how to fix this and get font rendering for Firefox working as it should be?
 

michael_hackson

Active Member

Thanks: 79
Messages: 146

#3
Hi! Can't at the moment give you any direct fix but I am joining this thread with the same interest. Out of the box, when newly installed and updated (without any font packages) Firefox renders well to me. My rendering issues started as soon I installed emulators/wine because their font packages actually override systemwise. This has been an ongoing issue for a while (would link but using secondary PC).

I am quite glad that fonts work and render well on my 2 systems apart from the wine override. It could be luck with the standard settings of my x11-wm/awesome but I think an idea would be to deinstall your fonts altogether and start clean. Though, if the fonts in Chrome looks clean and nice, have you tried changing to the same fonts in Firefox's settings?

If you indeed are a wine user I realised that the fonts from emulators/wine-staging render better than the ones from emulators/wine. Not really a direct fix as stated before but this saved my lazy hiney for going into some fonts config nitpicking.

Have you checked out this discussion already?
Thread HOWTO-Nicefonts.2021

Especially: "You just have to go to /usr/local/etc/fonts/conf.d and link to all the features you want in /usr/local/etc/fonts/conf.avail." – As stated by user kamikaze.
 
Last edited by a moderator:

Snurg

Aspiring Daemon

Thanks: 326
Messages: 794

#4
tobik@
I have not had this problem for a long time, so I just ask.
LibreOffice for example as well suffers from the problem also that under some circumstances embedded bitmap fonts intended for very small character sizes are being displayed instead of the vector fonts.
Will putting that link you suggested also disable these embedded bitmap fonts?


Edit: It will not. But there is a way to do that, see aragats post here
 
G

giahung1997

Guest


#6
This topic really needs an up-to-date, comprehensive How-To.

Font rendering in Firefox is hideous. The webfonts pkg does not change it and every suggestion I've found does not work.

Chromium looks fine.

Can anyone advise how to fix this and get font rendering for Firefox working as it should be?
I'm not expert so my answer could not help, but I try my best with my knowledge. On Linux, I observed that FF obeys fonts setting from the environment more than Chromium so usually it picked up the ugly fonts. I go to it preference, change default fonts to: Serif - Free Serif, Sans (Sans Serif) - Liberation Sans, Mono - Liberation Mono and uncheck allow site choose their own setting. Worked for me well.

p/s: with FreeSerif it look not very readable with small size so I'm also using Nosquint Plus addon :)
 
Top