Solved Firefox Crashses X Server

pinecat

New Member


Messages: 2

Hello,

I've been using FreeBSD for many years now on my servers, but I decided to try it out on my ThinkPad x220 with a desktop environment. I have setup Xorg on my machine, and I'm currently using awesome wm. I'm trying to configure awesome wm (i.e. setting up new keybinds, changing themes), and so I have to reload in order to see these changes (using the default keybinds Mod+Ctrl+r to reload awesome). The problem is, every time a perform a reload while I have an instance of Firefox running, my X server crashes. If I do not have any instances of Firefox running, I can reload my window manager without any issues.

I've collected some info about the crash as well.

Output from uname -r:
Code:
12.1-RELEASE

Output from firefox &> firefox-log.txt:
Code:
Log warning: The log 'Services.Common.RESTRequest' is configured to use the preference 'services.common.log.logger.rest.request' - you must adjust the level by setting this preference, not by using the level setter
JavaScript warning: moz-extension://accc7d4a-2bf2-4f57-acbb-be831d7b085f/lib/adblockplus.js, line 0: Successfully compiled asm.js code (total compilation time 2ms)
JavaScript error: resource://gre/modules/ExtensionCommon.jsm, line 2312: Error: primed listener not re-registered
Gdk-Message: 17:59:57.932: /usr/local/lib/firefox/firefox: Fatal IO error 35 (Resource temporarily unavailable) on X server :0.

Gdk-Message: 17:59:57.932: firefox: Fatal IO error 35 (Resource temporarily unavailable) on X server :0.

Xorg Log (/var/log/Xorg.0.log):
https://pastebin.com/0tg4hCBk
 

eternal_noob

Aspiring Daemon

Reaction score: 519
Messages: 747

According to the log, the problem is glamor (the 2d acceleration of Xorg). The Xorg version you are using is very old.

You could update Xorg to the latest version by switching your packages from quarterly to latest like this:

Create a new file /usr/local/etc/pkg/repos/FreeBSD.conf with the contents
Code:
FreeBSD: {
  url: "pkg+http://pkg.FreeBSD.org/${ABI}/latest"
}
and do pkg update -f.

Then reinstall Xorg.

Or you can disable glamor like this:
Code:
[xxx@xxx ~]$ cat /usr/local/etc/X11/xorg.conf.d/driver-modesetting.conf
Section "Device"
  Identifier "Intel Graphics"
  Driver     "modesetting"
  Option     "AccelMethod" "none"
EndSection
 
OP
P

pinecat

New Member


Messages: 2

Just got back from dinner and tested this out. Works like a charm! Switching to latest and reinstalling Xorg did the trick for me. Thanks for the help!
 
Top