firefox crashes Xorg

roelof

Well-Known Member

Reaction score: 2
Messages: 276

Hello,

Today I updated Cairo and another program. Now every time I start up FF X chrashes with these messages.

Code:
May 21 19:37:36 tamara kernel: pid 37421 (akonadiserver), uid 0: exited on signal 11 (core dumped)
May 21 19:37:37 tamara kernel: pid 37459 (akonadiserver), uid 0: exited on signal 11 (core dumped)
May 21 19:37:37 tamara kernel: pid 37466 (akonadiserver), uid 0: exited on signal 11 (core dumped)
May 21 19:37:38 tamara kernel: pid 37474 (akonadiserver), uid 0: exited on signal 11 (core dumped)
May 21 19:37:38 tamara kernel: pid 37480 (akonadiserver), uid 0: exited on signal 11 (core dumped)
May 21 19:37:39 tamara kernel: pid 37486 (akonadiserver), uid 0: exited on signal 11 (core dumped)
May 21 19:37:49 tamara dbus[1379]: [system] Failed to activate service 'org.freedesktop.Avahi': timed out
This is from /var/log/messages.

Roelof
 

adamk

Daemon

Reaction score: 266
Messages: 1,622

When updating port (A), you typically have to update/rebuild every other port that depends on (A). Have you rebuilt firefox?

BTW, none of the messages you provided appear to have anything to do with firefox.

Adam
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

No, I did not rebuild firefox. I only update the ports that can be updated or UPDATING tells me to rebuild everything that depends on that port.
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

I rebuilt Firefox but still the same problem. As soon as I start firefox X chrashes.

Roelof
 

adamk

Daemon

Reaction score: 266
Messages: 1,622

Well if X is crashing, maybe the X server has to be rebuilt. What does the /var/log/Xorg.0.log file say about the crash?

Adam
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

Xorg.0.log says this about the crash :
Code:
I) intel(0): Modeline "1440x900"x0.0  106.50  1440 1520 1672 1904  900 903 909 934 -hsync +vsync (55.9 kHz)
(II) intel(0): Modeline "1280x1024"x0.0  108.00  1280 1328 1440 1688  1024 1025 1028 1066 +hsync +vsync (64.0 kHz)
(II) intel(0): Modeline "1600x1200"x0.0  162.00  1600 1664 1856 2160  1200 1201 1204 1250 +hsync +vsync (75.0 kHz)
(II) intel(0): Modeline "1680x1050"x0.0  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync (65.3 kHz)
(II) intel(0): EDID vendor "PHL", prod id 49240
Segmentation fault: 11 at address 0x10

Fatal server error:
Caught signal 11 (Segmentation fault: 11). Server aborting


Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

(II) UnloadModule: "kbd"
(II) UnloadModule: "mouse"
(II) UnloadModule: "kbd"
(II) intel(0): xf86UnbindGARTMemory: unbind key 1
(WW) intel(0): drmDropMaster failed: Unknown error: -1
 

bela

New Member


Messages: 12

same thing here

I get the same error:
Code:
Fatal server error: Caught signal 11 (Segmentation fault: 11). Server aborting
This happened after updating the following ports (not sure which port is the culprit):

Code:
          devel/boost-libs (boost-libs-1.45.0_2) 
          textproc/libxml2 (libxml2-2.7.8_2) 
          x11-fonts/fontconfig (fontconfig-2.8.0_2,1)
          print/texinfo (texinfo-4.13.20120406)
          misc/shared-mime-info (shared-mime-info-1.0)
          graphics/cairo (cairo-1.10.2_3,1)
          graphics/gdk-pixbuf2 (gdk-pixbuf-2.23.5_1)
          multimedia/gpac-libgpac (gpac-libgpac-0.4.5_4,1)
          x11-toolkits/gtk20 (gtk-2.24.6)
          graphics/gegl (gegl-0.1.8_2)
          multimedia/x264 (x264-0.123.2189)
          multimedia/ffmpeg (ffmpeg-0.7.12,1)
Compile from ports went smoothly but firefox, thunderbird and chromium all crash X11 with the same error massage. This happened on a Thinkpad T61 laptop with an Intel X3100 graphics card, hopefully this helps.
 

alext

New Member


Messages: 4

I think the problem comes from cairo.
I've downgraded cairo to be able to startx again.
 

bela

New Member


Messages: 12

alext, you might have a different problem. X (with wmii) works just fine for me until I launch firefox, thunderbird or chromium.

Only "solution" I have found so far is to reinstall/downgrade the previously mentioned ports to their respective older versions (those in the previous post).
 

phoenix

Administrator
Staff member
Administrator
Moderator

Reaction score: 1,260
Messages: 4,099

There appears to be an issue with the newest Intel driver for Xorg conflicting with the newest version of Cairo. If you downgrade Cairo, everything works.

There's a thread about this on one of the mailing lists.
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

The new cairo seems to be a problem even if you don't have Intel.
 

jb_fvwm2

Daemon

Reaction score: 182
Messages: 1,696

Strange, I tested firefox etc with the new cairo, no problem here.
(Using the ati driver in xorg.conf)
 

wblock@

Beastie Himself
Developer

Reaction score: 3,649
Messages: 13,850

I saw text corruption in terminals and sometimes in Firefox.
 

timeout

New Member


Messages: 7

I have the same problem with intel, X and in particular xfce crashing. Any idea how long this is going to take?
 

z0ran

Member

Reaction score: 1
Messages: 48

same thing here, and i have ati driver...X is crashing only when i try to start firefox, opera, xxxterm or any other browser...any other application works with no problem...btw, i have i3-wm.
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

I can confirm that downgrading Cairo to 1.10 solve the problem.
So for me it's clear that cairo 1.12 is too blame.
 

jb_fvwm2

Daemon

Reaction score: 182
Messages: 1,696

Can someone facing those crashes run the application(s) before starting X? Sometimes it shows other shared libraries (cairo > ??? > firefox) that need to be rebuilt...
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

As far as I know Firefox cannot be run without a starting X.
 

jb_fvwm2

Daemon

Reaction score: 182
Messages: 1,696

roelof said:
As far as I know Firefox cannot be run without a starting X.
That is correct. But sometimes it will show "...not found, required by..." instead of "Cannot open DISPLAY" and a dependency rebuild is is order rather than a cairo downgrade, if you *attempt* to run it before X is started. (In the case of some browsers, one must locate the actual program name somewhere:
Code:
locate seamonkey-bin
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

I can try it with firefox, only I have to figure out how I can install the newer version of cairo. I think that making it from ports can help.
 
OP
OP
R

roelof

Well-Known Member

Reaction score: 2
Messages: 276

When startup in runlevel 3 I get this message:

Code:
Error: No display specified.
When you want me to try in another runlevel tell me how to proceed without starting X.
 
Top