Firefox Crashes my GPU on YouTube Videos

BawdyAnarchist

Member

Reaction score: 12
Messages: 94

System: FreeBSD 13.0-RELEASE-p3, Threadripper 3960x, RTX 2080, FF 90.0.0 and 90.0.2

Youtube videos will crash the GPU between 3-20 minutes. The video freezes, there's a buzzing sound for a couple seconds, and then all screens are frozen and input commands seem to do nothing. I can't even switch to a new TTYT, have to reset the computer. I have Falkon browser as well, and there is no problem with playing YT there. So something about FF is crashing my GPU into an unrecoverable state.

Where should I be looking for crash logs (I already checked /var/crash after giving the PC a couple hours to make a crash dump, but there was nothing there. So I think the system is still running, just that the GPU is frozen.

I also posted on reddit to the FF sub.
 

Tieks

Well-Known Member

Reaction score: 128
Messages: 307

BawdyAnarchist said:
So I think the system is still running

If it is still running, you don't have to look for dumps. You can find out by starting sshd and trying to ssh to the system when you have that problem. Use top to see what is choking the system.
 

astyle

Daemon

Reaction score: 653
Messages: 1,464

I posted some links in a different thread:
Following up on those for OP's hardware, I'm thinking that a newer Threadripper is not playing that well with an older NVidia card.
 
OP
B

BawdyAnarchist

Member

Reaction score: 12
Messages: 94

Does Cntrl-Alt-Fn still works ?

No I don't think so. I tried switching TTYS, but no response. Apparently what I need to do is SSH into the system to see what's happening, but I haven't had the time to troubleshoot, I'm not a dev or savvy to know what exactly to look for (other than ps aux or top). I'm also afraid of intentionally freezing the GPU again, as last time it took multiple power cycles just to get a the display working again. Seemed the motherboard was getting stuck at various error codes, and I had to power cycle 2-4 times.
 

roccobaroccoSC

Aspiring Daemon

Reaction score: 226
Messages: 750

System: FreeBSD 13.0-RELEASE-p3, Threadripper 3960x, RTX 2080, FF 90.0.0 and 90.0.2

Youtube videos will crash the GPU between 3-20 minutes. The video freezes, there's a buzzing sound for a couple seconds, and then all screens are frozen and input commands seem to do nothing. I can't even switch to a new TTYT, have to reset the computer. I have Falkon browser as well, and there is no problem with playing YT there. So something about FF is crashing my GPU into an unrecoverable state.

Where should I be looking for crash logs (I already checked /var/crash after giving the PC a couple hours to make a crash dump, but there was nothing there. So I think the system is still running, just that the GPU is frozen.

I also posted on reddit to the FF sub.
I had exactly the same problem with Threadripper 1, AMD RX 580 and 12.0-RELEASE + 12.1-RELEASE for a solid year. Eventually I gave up looking for a solution, I asked around in forums but never solved it.
Someone told me it's probably the CPU which is kind of tweaked to work on the edge of possible and by design has some micro crashes that mess up the kernel from time to time. I don't know how to validate that.
After giving up I installed Linux on the machine and since then I have never ever seen the bug. The hardware is probably tweaked to the Linux drivers by AMD and unfortunately they did not invest in tuning FreeBSD too.
I hope this helps, but if you find a solution let me know.

Here is a link to my original post: https://forums.freebsd.org/threads/sounds-stops-working-sporadically-restart-is-required.69855/
 
Top