Solved Firefox 89.0.1 Laggy after update.

OJ

Daemon

Reaction score: 401
Messages: 1,255

I updated my machine a couple of days ago and all seems fine, except Firefox which is barely usable now.

FreeBSD 12.2-RELEASE-p3 GENERIC amd64
Intel Core i9-9900K 3.6GHZ 16MB Cache / 64GB Ram
KDE Plasma Version 5.20.5
KDE Frameworks Version 5.80.0
QT Version 5.15.2

I get delays around 2 to 4 seconds. Scrolling is jerky, again 2-4s delay. Pasting text can take much longer for the cursor to show up.
Just to make sure there is no network problem I tried Chromium, and it's as fast as should be. I assume this is a FreeBSD problem and not Firefox.

Any suggestions on how to correct this problem would be greatly appreciated.

~ Ole

PS: I just noticed Kinfocenter reports FreeBSD 12.1, if that's of any importance.
 

bsduck

Active Member

Reaction score: 204
Messages: 245

Did you already have Firefox 89.0 before updating, or an older release?

Beginning with 89.0 WebRender is enabled by default.
I also noticed some performance issues so I opted for gfx.webrender.force-disabled=true and it works fine again.
 
OP
OJ

OJ

Daemon

Reaction score: 401
Messages: 1,255

bsduck That's an excellent question, and I don't know. All I know is what I have now.
 
OP
OJ

OJ

Daemon

Reaction score: 401
Messages: 1,255

Have you checked to make sure you are OK? uname -a

Yes, I always check uname -a and that's what I quoted in the OP. I'm not generally concerned about what KDE says and rarely look at that. I just happened to look now for the first time in what is probably a couple of years. lol
 

Trihexagonal

Son of Beastie

Reaction score: 2,434
Messages: 2,953

I always use Firefox-ESR. It seemed more stable for a long time, although they might have worked on Firefox Ultraman Version since then:

firefox-esr.jpg
 
  • Thanks
Reactions: OJ
OP
OJ

OJ

Daemon

Reaction score: 401
Messages: 1,255

How many modified webrender preferences do you have, now?


I just have the one that was suggested above. I think I'll leave it at that unless another problem shows up.

I wonder if I didn't have some webrender problems before because now the browser seems faster than it's ever been.
 
OP
OJ

OJ

Daemon

Reaction score: 401
Messages: 1,255

Thanks. If DRM is a factor in your case: looking ahead, you'll get better DRM with FreeBSD 13.⋯



Which version of FreeBSD? What's your graphics hardware?

Here: <https://bsd-hardware.info/?computer=8f084339058d>

I don't know what DRM means in this context. Sorry.

As stated in my the OP: FreeBSD 12.2-RELEASE-p3 GENERIC amd64 :) It's a Supermicro C9Z390-CG/CGW Motherboard and I'm using the Intel integrated graphics. I have no use for a graphics card since it won't make anything faster.
 

grahamperrin

Daemon

Reaction score: 694
Messages: 2,211

Sorry, the questions about software and hardware are for bsduck (in response to the bsduck quote); to compare with what's in your opening post.

I don't know what DRM means in this context. …

FreeBSD context:
Generally:

 
  • Thanks
Reactions: OJ

tingo

Son of Beastie

Reaction score: 638
Messages: 2,544

Did you already have Firefox 89.0 before updating, or an older release?

Beginning with 89.0 WebRender is enabled by default.
I also noticed some performance issues so I opted for gfx.webrender.force-disabled=true and it works fine again.
It seems that this setting has restored responsiveness to my Firefox (89.0_2,2). Very nice.
 

grahamperrin

Daemon

Reaction score: 694
Messages: 2,211

13.0-RELEASE on Intel HD Graphics 4000

Thanks, with which software do you drive the Intel HD Graphics 4000?

Is x11-drivers/xf86-video-intel installed, or not?


(Here's a 12.1-RELEASE-p10 example of vgapci <https://bsd-hardware.info/?probe=9fb23e0394#d12> when i915 might have been better.)
 

tingo

Son of Beastie

Reaction score: 638
Messages: 2,544

tingo which version of FreeBSD? What's your graphics hardware¸ and which software drives it?
Here are the details:
Code:
root@kg-core2# freebsd-version -ku
11.4-RELEASE-p9
11.4-RELEASE-p9
a MSI R5 230 2GD3H LP - Radeon R5 230 graphics card (I like it silent)
Code:
root@kg-core2# pciconf -lv | grep -A 4 VGA
    subclass   = VGA
hdac0@pci0:7:0:1:    class=0x040300 card=0xaa981462 chip=0xaa981002 rev=0x00 hdr=0x00
    vendor     = 'Advanced Micro Devices, Inc. [AMD/ATI]'
    device     = 'Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM / R5 230/235/235X OEM]'
    class      = multimedia
software
Code:
root@kg-core2# pkg info drm* gpu*
drm-fbsd11.2-kmod-4.11g20200420_1
gpu-firmware-kmod-g20210330
 

bsduck

Active Member

Reaction score: 204
Messages: 245

Mozilla has a strange logic, gfx.webrender.enabled = false does not disable WebRender and one has to use gfx.webrender.force-disabled = true to effectively disable it... please, why?
 
Top