Solved firefox 61: U2F / FIDO does not work

patpro

Active Member

Reaction score: 16
Messages: 238

Hi all,

I've installed the latest Firefox package (firefox-61.0.1_1,1) on my FreeBSD 11.2-RELEASE, and activated u2f (security.webauth.u2f -> true), but the yubikey is not activated/recognized by Firefox.

Any idea?
 

woodsb02

Active Member

Reaction score: 71
Messages: 165

Thanks for that, indeed that worked for me.

Note the additional setup instructions when you install security/u2f-devd (which can be found here):
Code:
U2F authentication requires read/write access to USB devices. To
facilitate such access it comes with a devd.conf(5) file, but you
still need to restart devd(8), add the desired users to "u2f" group
and log those out of the current session. For example:

# service devd restart
# pw group mod u2f -m <user>
$ exit

For details, see /usr/local/etc/devd/u2f.conf
 

iandstanley

New Member


Messages: 3

Hi

I managed to get u2f/fido working on my own before I found this.

Does anybody know what needs to be done to get FIDO2 working with firefox and a yubikey 5

I have libfido2 running
 
Top