Solved Firefox 35 on fresh FreeBSD 10.1

happyzik

New Member

Reaction score: 1
Messages: 8

Hi all,

I'm very new to BSD, though I have some experience using Linux.

Well, today I setup a fresh FreeBSD 10.1, everything was fine until I tried to install firefox. To do so, I just typed: pkg install firefox

Code:
%pkg info firefox
firefox-35.0.1_1,1
Name : firefox
Version : 35.0.1_1,1
...
I also set up Xorg and WindowMaker before.
When I try to launch firefox, I only have this error:

Code:
% firefox &

(process:925): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
process 925: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory
See the manual page for dbus-uuidgen to correct this issue.
D-Bus not compiled with backtrace support so unable to print a backtrace
Abandon(core dumped)
A dump file is then created.
Searching on internet tells me those messages aren't so important (firefox runs fine on some people having those messages as well).

dmesg says pid 925 (firefox), uid 1001: exited on signal 6 (core dumped). This is also the only message I can find in /var/log/ directory.

Actually, I don't know what is the next step to find what is wrong. Maybe I should try ports, but as I said above I'm very new to BSD...

Thanks for you help !
 

tobik@

Daemon
Developer

Reaction score: 1,401
Messages: 1,909

Run gdb -ex bt --batch /usr/local/bin/firefox ~/firefox.core and post the output here.

This should print a stacktrace, which could help in narrowing the problem down.

Another thing: Did you add dbus_enable="YES" to your /etc/rc.conf?
 
OP
H

happyzik

New Member

Reaction score: 1
Messages: 8

Shame on me... I didn't enable d-bus... Now it works...

Thank you very much tobik! I even didn't know the gdb trick, I'll write it down on a post-it.
 

Juanitou

Well-Known Member

Reaction score: 126
Messages: 453

I think you missed the message printed by pkg(8) about the rc.conf knob when DBUS was installed as a dependency.
 
Top