Solved File /usr/local/share/cpupdate/CPUMicrocodes/secondary/Intel/06-9e-0d: Read error!

Hello.

I've updated FreeBSD 13 release to 14 current,but between the boot messages of 14,I can read :

Code:
Found CPU(s) from Intel
File /usr/local/share/cpupdate/CPUMicrocodes/secondary/Intel/06-9e-0d:
Read error! /etc/rc: WARNING: failed to start cpupdate

how to fix it ?
 
How about trying to debug the problem yourself:

Does the file exist? Is it readable? What are the permissions? Do you have disk IO errors in the log? Try reading it 10 times in a row (perhaps with reboots in between to clear the read cache in the file system).

If all that succeeds: Look at the source code for cpupdate, and see when it issues that message, and what conditions can lead to it. If you run CURRENT, you will debug it yourself. And you are on your own with all other debugging on your system.
 
I don't agree often with you, but this time i do.

The sub-forums description is
Kernel development, writing drivers, coding, and questions regarding FreeBSD internals.
No word about exclusion of -CURRENT.

I think discussion about -CURRENT should be allowed here. If not, please change the forum description to reflect that.
 
pkg delete -f cpupdate

Code:
# pkg delete -f cpupdate

Checking integrity... done (0 conflicting)
Deinstallation has been requested for the following 1 packages (of 0 packages in the universe):

Installed packages to be REMOVED:
cpupdate: g20180513_3

Number of packages to be removed: 1

Proceed with deinstalling packages? [y/N]: y
[1/1] Deinstalling cpupdate-g20180513_3...
[1/1] Deleting files for cpupdate-g20180513_3: 100%

@marietto:~ # ls /usr/local/share/cpupdate/

ls: /usr/local/share/cpupdate/: No such file or directory

@marietto:~ # /usr/ports/sysutils/cpupdate # make deinstall clean

===>  Deinstalling for cpupdate
===>   cpupdate not installed, skipping
===>  Cleaning for cpupdate-g20180513_3

@marietto:/usr/ports/sysutils/cpupdate # make

pkg-static: Bad argument on pkg_set 556310713
===>  License BSD2CLAUSE accepted by the user
===>   cpupdate-g20180513_3 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by cpupdate-g20180513_3 for building
===>  Extracting for cpupdate-g20180513_3
=> SHA256 Checksum OK for kernschmelze-cpupdate-g20180513-48e42d5_GH0.tar.gz.
===>  Patching for cpupdate-g20180513_3
/usr/bin/sed -i.bak -e "s,/usr/local/share/cpupdate,/usr/local/share/cpupdate,g" /usr/ports/sysutils
/cpupdate/work/cpupdate-48e42d5/cpupdate.h
===>  Configuring for cpupdate-g20180513_3
===>  Building for cpupdate-g20180513_3
--- objwarn ---
--- .depend ---
--- objwarn ---
Warning: Object directory not changed from original /usr/ports/sysutils/cpupdate/work/cpupdate-48e42
d5
--- .depend ---
echo cpupdate: /usr/lib/libc.a  >> .depend
--- cpupdate.o ---
--- intel.o ---
--- cpupdate.8.gz ---
--- cpupdate.o ---
cc  -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing    -fPIE -MD  -MF.depend.cpupdate.o -MT
cpupdate.o -std=gnu99 -Wno-format-zero-length -nobuiltininc -idirafter /usr/lib/clang/13.0.0/include
-fstack-protector-strong    -Qunused-arguments    -c cpupdate.c -o cpupdate.o
--- intel.o ---
cc  -O2 -pipe  -fstack-protector-strong -fno-strict-aliasing    -fPIE -MD  -MF.depend.intel.o -MTint
el.o -std=gnu99 -Wno-format-zero-length -nobuiltininc -idirafter /usr/lib/clang/13.0.0/include -fsta
ck-protector-strong    -Qunused-arguments    -c intel.c -o intel.o
--- cpupdate.8.gz ---
gzip -cn cpupdate.8 > cpupdate.8.gz
--- cpupdate ---
cc -O2 -pipe -fstack-protector-strong -fno-strict-aliasing -fPIE -std=gnu99 -Wno-format-zero-length
-nobuiltininc -idirafter /usr/lib/clang/13.0.0/include -fstack-protector-strong -Qunused-arguments 
-fstack-protector-strong  -pie   -o cpupdate cpupdate.o intel.o 
===>  Staging for cpupdate-g20180513_3
===>   Generating temporary packing list
install  -s -m 555 /usr/ports/sysutils/cpupdate/work/cpupdate-48e42d5/cpupdate /usr/ports/sysutils/c
pupdate/work/stage/usr/local/sbin
install  -m 444 /usr/ports/sysutils/cpupdate/work/cpupdate-48e42d5/cpupdate.8 /usr/ports/sysutils/cp
update/work/stage/usr/local/man/man8
====> Compressing man pages (compress-man)
===> Staging rc.d startup script(s)

@marietto:/usr/ports/sysutils/cpupdate # make install

===>  Installing for cpupdate-g20180513_3
===>  Checking if cpupdate is already installed
===>   Registering installation for cpupdate-g20180513_3
Installing cpupdate-g20180513_3...
NOTE: The following directories

/usr/ports/sysutils/cpupdate/work/CPUMicrocodes-044f53b
/usr/ports/sysutils/cpupdate/work/Intel-Linux-Processor-Microcode-Data-Files-microcode-20210216/intel-ucode

contain Intel and/or platomav/CPUMicrocodes collections respectively. if you have just built the port with corresponding CPM/INTEL option(s) enabled. In this case you can run "make install-microcodes" to install them to /usr/local/share/cpupdate

If you installed the package then you may download microcodes with following command:
service cpupdate download

@marietto:/usr/ports/sysutils/cpupdate # service cpupdate download

Installing microcodes to /usr/local/share/cpupdate ... done.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
NOTE: you have to manually remove the directory
/usr/local/share/cpupdate
after deinstallation of cpupdate.
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

REBOOT : FIXED.

thanks.
 
So we have no idea what was wrong, but that a uninstall/reinstall/reboot fixed the problem. That's not much information.
 
What it doesn't work has been reinstalling the binary. It worked only installing cpupdate from ports with the command cd /usr/ports/sysutils/cpupdate & make install
 
Top