Solved ffplay not installed with ffmpeg does it require sdl

NapoleonWils0n

Well-Known Member

Reaction score: 151
Messages: 275

When you install the ffmpeg package ffplay isnt installed

Looking at the ffmpeg freshports page there is a comment for ffplay
@comment bin/ffplay

I may be wrong but i think ffplay requires sdl which is off by default in the config options
SDL=off: Simple Direct Media Layer support

Can anyone confirm that to install ffplay that ffmpeg needs to be built with SDL=on

And which version of sdl should be installed sdl or sdl2

The reason i need to install ffplay is to test audio filters for recordings,
and use the ffplay ebu128 realtime graph

Bash:
ffplay -f lavfi -i "amovie=input.mp3,ebur128=video=1:meter=18 [out0][out1]"

I presume just installing sdl or sdl2 and then reinstalling ffmpeg wouldnt work

Would i be right thinking i would need to use poudriere to build ffmpeg with SDL=on to enable ffplay
I have already set up poudriere to build packages

Do i need to uninstall the current version of ffmpeg and all packages that depend on ffmpeg
then build and install a new ffmpeg package with poudriere with SDL=on

And then reinstall all the packages i uninstalled that require ffmpeg again

Or is there a easier way

Its a real shame ffplay isnt installed with ffmpeg as its very useful for testing audio and video filters

If building ffmpeg with poudriere is the only option to enable ffplay,
then i will do a full write up of the steps involved

If anyone could shed some light on how to get ffplay installed id be very gratefull

Cheers
 

shkhln

Daemon

Reaction score: 1,067
Messages: 2,398

Ok, I'll bite. 1 sentence per paragraph, no periods, no question marks. All followed very consistently. Wtf?

As for the question itself, look here and here.
 
OP
NapoleonWils0n

NapoleonWils0n

Well-Known Member

Reaction score: 151
Messages: 275

Ok, I'll bite. 1 sentence per paragraph, no periods, no question marks. All followed very consistently. Wtf?

As for the question itself, look here and here.
I was in a rush before i had to pop out.

British comprehensive education in the 80s after all the Tory cuts,
we didnt do all that la-de-da stuff like spelling and punctuation.

I think i may have installed ffmpeg before installing a package that pulled in sdl2 as a dependency,
so that might be why i dont have ffplay installed, because i didnt have sdl2 installed when i installed ffmpeg.

Im pretty sure i had ffplay on a previous install of Freebsd,
ill try reinstalling ffmpeg and see what happens

Thanks for the links
 

shkhln

Daemon

Reaction score: 1,067
Messages: 2,398

I think i may have installed ffmpeg before installing a package that pulled in sdl2 as a dependency,
so that might be why i dont have ffplay installed, because i didnt have sdl2 installed when i installed ffmpeg.

No, it's not installed because it's not in the package. You need to build the ffmpeg port with the sdl option.
 

cabriofahrer

Well-Known Member

Reaction score: 20
Messages: 256

I bumped into this problem, too, as kdenlive misses ffplay as well. So thanks to this thread I had the solution immediately. I think the easiest way to fix this is by just recompiling multimedia/ffmpeg the following way:

cd /usr/ports/multimedia/ffmpeg
make config and there select the option "sdl"
make deinstall
make reinstall

That's it!
 
Top