Failure Upgrading from 11.0 to 11.1 with Digital Ocean Droplet

russellfolk

New Member


Messages: 2

Good evening, y'all,

I recently tried updating my secondary droplet to 11.1 using the freebsd-update instructions. It worked great on my VM machine and seemed to work great on my droplet. I finished the first reboot, ran `freebsd-update install` and it seemed to be going well then things crapped out. I got all sorts of errors then got kicked out. It's as if none of the admin functions are still around. Can't ssh in, etc. I did try rebooting again via the power-cycle but that is still leaving me at the same spot.

Is there any hope? This was a default droplet as originally configured with after system services setup.

I'm not sure what logs to get from where to help, so I will try to be as helpful as possible to help y'all help me.

Thanks for your time.
 

drhowarddrfine

Son of Beastie

Reaction score: 2,294
Messages: 4,273

I got all sorts of errors then got kicked out.
Did you happen to copy those errors?

It's as if none of the admin functions are still around.
Admin functions? What do you mean by that? If you mean DO admin then you'd have to talk to them.

You say you can't ssh in but can you get to a terminal through DO's control panel?
 
OP
R

russellfolk

New Member


Messages: 2

I'm sorry for the delay.

Did you happen to copy those errors?


Admin functions? What do you mean by that? If you mean DO admin then you'd have to talk to them.

You say you can't ssh in but can you get to a terminal through DO's control panel?

Basically, it's as if /usr/bin, /usr/sbin, and the like are gone. I can't seem to get in through console (), I can't get in through ssh, I haven't looked into single user mode.

DO-Screenshot.png


What spot?

Basically, after running `freebsd-update install` after the reboot (fetch, install, reboot, this install), I had scrolling errors of cannot remove files or create, I can't remember and I got kicked out and didn't grab a screen shot.

I was originally on a ZFS started 11.0 droplet if that's any help, not sure if I could do a rollback or how I would get there...
 

monwarez

Active Member

Reaction score: 58
Messages: 142

I did have this issue for networking, you will have to first put the correct ip value for network in /etc/rc.conf and restart network. Then if it is working, you will be able to download the fix https://github.com/digitalocean/freebsd-fix
Here a communication from the support (they have mounted the recovery iso, which is GNU/Linux based, so you can use it to mount your filesystem and download the fix). After setting the fix, you can try to use it in single mode

Hi there,

Updating FreeBSD versions can break the networking on a FreeBSD Droplet. This is in part to how FreeBSD handles the update and how we assign the networking configuration. This script can fix this:

https://github.com/digitalocean/freebsd-fix

Because the Droplet is offline you'll need access to it again. The Droplet is set to boot our recovery ISO. To use this you'll need to power it down and then power it back on. If you have an SSH key for the root user you can ssh into the Droplet with that key, otherwise you'll want to use the console to find the ssh root password to access it or use the console to work with the ISO.

Connecting to the console is very simple, you can do so by logging into your control panel here: https://cloud.digitalocean.com Once here, select your droplet -> Select Access -> Select "access console". This will open a new window where you can login to the Droplet. You may need to click the window and hit any key to wake up the console. The console doesn't allow copy and paste.

Additional guides for using this ISO can be found here:
https://www.digitalocean.com/commun...stem-corruption-using-fsck-and-a-recovery-iso
https://www.digitalocean.com/commun...-a-compromised-droplet-using-the-recovery-iso
https://www.digitalocean.com/commun...to-sync-local-and-remote-directories-on-a-vps

When you are done with the recovery ISO let us know and we'll set the boot order on your Droplet back to your Droplet disk.


Best,
Dane
DigitalOcean Platform Support


Check out our community for great tutorials, articles, and FAQs!
https://digitalocean.com/community
 
Top