• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Solved Failure in xfce4-panel, the panel this running in kiosk mode!

teo

Well-Known Member

Thanks: 6
Messages: 381

#1
Hello community!


Does anyone know why that message is displayed in small windows at each startup session of xfce? These little windows and the xfce4-panel are automatically displayed with that message, and the taskbar is not displayed. How to proceed to solve that?


Code:
Modification of the panel is not allowed

Panel is running in kiosk mode. You are not allowed to make changes to panel settings.

Code:
No instance found of xfce4-panel in execution.
 

k.jacker

Well-Known Member

Thanks: 157
Messages: 330

#2
Stuff that runs on top of Xorg is in most cases not FreeBSD specific, so checking the corresponding resource often does the trick.
A quick search in the XFCE Wiki at https://wiki.xfce.org/howto/kiosk_mode reveals that you have to be in the %poweruser group (which should be wheel in FreeBSD) to change the panel. If you are not in the wheel group you could add your username to kioskrc.

Is it the only the xfce-panel you can not change? I've never experienced that, though my user is allways member of wheel :D

Still I think it's weird that it's calles kiosk mode, that shouldn't be enabled by default, but maybe it's like that when you're not member of the wheel group...
I would have testet it on my XFCE but I'm not at home.

To break it down, try adding your user to the wheel group or add your username to /usr/local/etc/xdg/xfce4/kiosk/kioskrc (not 100% sure if that is the right path. you might have to create the file as well) as shown on the wiki page.

If you are allready member of wheel then I don't know how to handle that...
 

teo

Well-Known Member

Thanks: 6
Messages: 381

#3
k.jacker said:
Is it the only the xfce-panel you can not change? I've never experienced that, though my user is allways member of wheel :D

To break it down, try adding your user to the wheel group or add your username to /usr/local/etc/xdg/xfce4/kiosk/kioskrc (not 100% sure if that is the right path. you might have to create the file as well) as shown on the wiki page.

If you are allready member of wheel then I don't know how to handle that...
For the user in the wheel group I always add it, and this is the xfce-generated file for the session in the .cache folder. :)

Edited:

Well, I've already to fix it this way, remove the xfce4-panel.xml from the directory in the /home/user/.config/xfce4/xfconf/xfce-perchannel-xml/ folder and also remove everything that was inside the sessions folder from the /home/user/.cache/sessions/ directory, and restart the system.
 
Top