Failed to load module "intel"

rockzombie2

Member

Reaction score: 15
Messages: 38

I'm having trouble getting my dual monitor setup to work. I have my first monitor "Screen0" plugged into my motherboard (intel, at least I think so). I have my second monitor plugged into my nvidia graphics card, "Screen1". I can get the Screen0 to work if I have my driver set to "modesetting". I can also get the second monitor (Screen1) to work if I specify the PCI bus as "PCI:1:0:0". However, then Screen0 does not work.

I've tried messing around with it a bit and at one point I had my first screen working with the second one connected, but only showing a black screen with a "X" cursor. Not sure how to get it back to that state.

I've tried following the instructions here, but it still can't find the intel driver. I've tried installing it via pkg and ports, but to no avail. I'm running out of ideas, please help :)

INFO:

Xorg.0.log
Code:
[   384.499] 
X.Org X Server 1.18.4
Release Date: 2016-07-19
[   384.499] X Protocol Version 11, Revision 0
[   384.499] Build Operating System: FreeBSD 12.0-RELEASE-p12 amd64 
[   384.499] Current Operating System: FreeBSD freeBSD 12.0-RELEASE FreeBSD 12.0-RELEASE r341666 GENERIC amd64
[   384.499] Build Date: 02 January 2020  09:07:34AM
[   384.499]  
[   384.499] Current version of pixman: 0.38.4
[   384.499]     Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
[   384.499] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   384.500] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Feb 10 20:50:26 2020
[   384.500] (==) Using config file: "/etc/X11/xorg.conf"
[   384.500] (==) ServerLayout "X.org Configured"
[   384.500] (**) |-->Screen "Screen0" (0)
[   384.500] (**) |   |-->Monitor "Monitor0"
[   384.500] (**) |   |-->Device "Card0"
[   384.500] (**) |-->Screen "Screen1" (1)
[   384.500] (**) |   |-->Monitor "Monitor1"
[   384.500] (**) |   |-->Device "Card1"
[   384.500] (**) |-->Input Device "Mouse0"
[   384.500] (**) |-->Input Device "Keyboard0"
[   384.500] (==) Automatically adding devices
[   384.500] (==) Automatically enabling devices
[   384.500] (==) Not automatically adding GPU devices
[   384.500] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   384.500] (**) FontPath set to:
    /usr/local/share/fonts/misc/,
    /usr/local/share/fonts/TTF/,
    /usr/local/share/fonts/OTF/,
    /usr/local/share/fonts/Type1/,
    /usr/local/share/fonts/100dpi/,
    /usr/local/share/fonts/75dpi/,
    catalogue:/usr/local/etc/X11/fontpath.d,
    /usr/local/share/fonts/misc/,
    /usr/local/share/fonts/TTF/,
    /usr/local/share/fonts/OTF/,
    /usr/local/share/fonts/Type1/,
    /usr/local/share/fonts/100dpi/,
    /usr/local/share/fonts/75dpi/,
    catalogue:/usr/local/etc/X11/fontpath.d
[   384.500] (**) ModulePath set to "/usr/local/lib/xorg/modules"
[   384.500] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   384.500] (WW) Disabling Mouse0
[   384.500] (WW) Disabling Keyboard0
[   384.500] (II) Loader magic: 0x421020
[   384.500] (II) Module ABI versions:
[   384.500]     X.Org ANSI C Emulation: 0.4
[   384.500]     X.Org Video Driver: 20.0
[   384.500]     X.Org XInput driver : 22.1
[   384.500]     X.Org Server Extension : 9.0
[   384.500] (!!) More than one possible primary device found
[   384.500] (--) PCI: (0:0:2:0) 8086:5912:1462:7a66 rev 4, Mem @ 0xdd000000/16777216, 0xb0000000/268435456, I/O @ 0x0000f000/64, BIOS @ 0x????????/65536
[   384.500] (--) PCI: (0:1:0:0) 10de:1c02:3842:6162 rev 161, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/65536
[   384.500] (II) "glx" will be loaded. This was enabled by default and also specified in the config file.
[   384.500] (II) LoadModule: "glx"
[   384.500] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   384.501] (II) Module glx: vendor="X.Org Foundation"
[   384.501]     compiled for 1.18.4, module version = 1.0.0
[   384.501]     ABI class: X.Org Server Extension, version 9.0
[   384.501] (==) AIGLX enabled
[   384.501] (II) LoadModule: "intel"
[   384.501] (WW) Warning, couldn't open module intel
[   384.501] (II) UnloadModule: "intel"
[   384.501] (II) Unloading intel
[   384.501] (EE) Failed to load module "intel" (module does not exist, 0)
[   384.501] (II) LoadModule: "nvidia"
[   384.501] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[   384.501] (II) Module nvidia: vendor="NVIDIA Corporation"
[   384.501]     compiled for 1.6.99.901, module version = 1.0.0
[   384.501]     Module class: X.Org Video Driver
[   384.501] (II) NVIDIA dlloader X Driver  440.31  Sun Oct 27 02:13:23 UTC 2019
[   384.501] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[   384.501] (--) Using syscons driver with X support (version 0.x)
[   384.501] (--) using VT number 9

[   385.486] (EE) No devices detected.
[   385.486] (EE) 
Fatal server error:
[   385.486] (EE) no screens found(EE) 
[   385.486] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[   385.486] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   385.486] (EE) 
[   386.484] (EE) Server terminated with error (1). Closing log file.

/etc/X11/xorg.conf
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 396.24  (root@freeBSD)  Sun Feb  2 00:48:10 EST 2020


Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath      "/usr/local/lib/xorg/modules"
    FontPath        "/usr/local/share/fonts/misc/"
    FontPath        "/usr/local/share/fonts/TTF/"
    FontPath        "/usr/local/share/fonts/OTF/"
    FontPath        "/usr/local/share/fonts/Type1/"
    FontPath        "/usr/local/share/fonts/100dpi/"
    FontPath        "/usr/local/share/fonts/75dpi/"
    FontPath        "catalogue:/usr/local/etc/X11/fontpath.d"
EndSection

Section "Module"
    Load           "glx"
    # Load           "glxserver_nvidia"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/sysmouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Monitor"
    Identifier     "Monitor1"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Device"
    Identifier     "Card0"
    Driver         "intel"
    # BusID          "PCI:1:0:0"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "kmsdev"                 # <str>
        #Option     "ShadowFB"               # [<bool>]
        #Option     "AccelMethod"            # <str>
        #Option     "PageFlip"               # [<bool>]
        #Option     "ZaphodHeads"            # <str>
    Identifier     "Card1"
    Driver         "nvidia"
    # BusID          "PCI:0:2:0"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

Section "Screen"
    Identifier     "Screen1"
    Device         "Card1"
    Monitor        "Monitor1"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       1
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection

/etc/rc.conf
Code:
clear_tmp_enable="YES"
hostname="freeBSD"
ifconfig_em0="DHCP"
sshd_enable="YES"
moused_enable="YES"
ntpdate_enable="YES"
ntpd_enable="YES"
# Set dumpdev to "AUTO" to enable crash dumps, "NO" to disable
dumpdev="AUTO"
zfs_enable="YES"
kld_list="/boot/modules/i915kms.ko nvidia-modeset"
 
OP
rockzombie2

rockzombie2

Member

Reaction score: 15
Messages: 38

Bump. I'm still having this issue. I can get both monitors to work if I plug them both into my nvidia graphics card, but then I don't have a screen available if X is not started (since nothing is plugged into my motherboard).
 

SirDice

Administrator
Staff member
Administrator
Moderator

Reaction score: 12,744
Messages: 39,332

The NVidia driver replaces a few Xorg libraries, the Intel driver expects the standard Xorg libraries. I'm not sure it's even possible to have both active at the same time.
 

shkhln

Daemon

Reaction score: 992
Messages: 2,286

plug them both into my nvidia graphics card, but then I don't have a screen available if X is not started (since nothing is plugged into my motherboard).

Double-check your BIOS/UEFI settings. There should a setting named Primary Graphics Adapter (or something similar to that) and it should be set to PCIe.
 
OP
rockzombie2

rockzombie2

Member

Reaction score: 15
Messages: 38

Oh, so you mean I can choose nvidia to be my primary graphics card in my UEFI settings? That might work. I hope. If not, then I guess per SirDice's answer, I can't use both. Thank you, if it doesn't work, I'll post another update.
 
Top