Xfce F1 & F10 in Midnight Commander

balanga

Daemon

Thanks: 95
Messages: 2,338

#1
When running midnight commander under Xfce I find that must function keys work normally except F1 and F10 which are intercepted by Xfce. Not sure if it's just Xfce or all WMs, but is there any way to stop the WM intervening?

Also how do I access command history? Normally Alt-h is used but using a WM Alt-h brings up an Xfce help screen.
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,520
Messages: 27,956

#2
It's XFCE that captures those keys before they're sent to the terminal. Gnome terminal suffers from something similar and captures F10 before mc gets it. That feature is easily turned off in the Gnome terminal options, I'm sure you can turn those keys off in XFCE too.
 
OP
OP
B

balanga

Daemon

Thanks: 95
Messages: 2,338

#4
It's XFCE that captures those keys before they're sent to the terminal. Gnome terminal suffers from something similar and captures F10 before mc gets it. That feature is easily turned off in the Gnome terminal options, I'm sure you can turn those keys off in XFCE too.
Desktop -> Applications -> Settings -> Settings Editor -> Channel ....

and then I get lost....
 

SirDice

Administrator
Staff member
Administrator
Moderator

Thanks: 6,520
Messages: 27,956

#5
Are you looking for the Gnome Terminal setting? Just open Gnome Terminal and navigate to "Edit" -> "Keyboard shortcuts". Turn off "Enable the menu shortcut key (F10 by default)".
 
OP
OP
B

balanga

Daemon

Thanks: 95
Messages: 2,338

#6
This is what worked for me on Xfce...

Desktop -> Open Terminal Here -> Edit -> Preferences -> Advanced

Shortcuts

Select 'Disable menu shortcut key (F10)'
Select 'Disable help window shortcut key (F1)'
 
Top