ezjail at start can't find indexinfo distr

mrpsycho

New Member


Messages: 6

Hello,

tried to find similar problem... but it looks like nobody got it.

so, I'm trying to make different flavours with installing software from ports.
and for example, i can't install ports-mgmt/portdowngrade cause of:

Code:
Making all in m4
Making all in tests
===>  Staging for gettext-runtime-0.19.8.1
===>   gettext-runtime-0.19.8.1 depends on executable: indexinfo - not found
===>   gettext-runtime-0.19.8.1 depends on executable: indexinfo - not found
*** Error code 1

Stop.
make[3]: stopped in /basejail/usr/ports/devel/gettext-runtime
*** Error code 1

Stop.
make[2]: stopped in /basejail/usr/ports/devel/gettext-tools
*** Error code 1

Stop.
make[1]: stopped in /basejail/usr/ports/devel/subversion
*** Error code 1

Stop.
make: stopped in /basejail/usr/ports/ports-mgmt/portdowngrade

and this is sick, cause after starting jail I may see it:
Code:
root@erlang18_09:~ # whereis indexinfo
indexinfo: /usr/local/bin/indexinfo /usr/ports/print/indexinfo
also, i had tried to install indexinfo via pkg and via /usr/ports/print/indexinfo
but it doesn't help

what do you recommend to install this?
 

chrbr

Aspiring Daemon

Reaction score: 241
Messages: 670

I have tried to build ports-mgmt/portdowngrade with ports-mgmt/poudriere and it works. The lines related to print/indexinfo are
Code:
===>   portdowngrade-1.5 depends on executable: svn - not found
===>   Installing existing package /packages/All/subversion-1.9.4.txz
[pkg.esprimo.local] Installing subversion-1.9.4...
[pkg.esprimo.local] `-- Installing expat-2.2.0...
[pkg.esprimo.local] `-- Extracting expat-2.2.0: .......... done
[pkg.esprimo.local] `-- Installing serf-1.3.9_1...
[pkg.esprimo.local] |   `-- Installing apr-1.5.2.1.5.4_2...
[pkg.esprimo.local] |   | `-- Installing gdbm-1.12...
[pkg.esprimo.local] |   |   `-- Installing indexinfo-0.2.6...
[pkg.esprimo.local] |   |   `-- Extracting indexinfo-0.2.6: .... done
[pkg.esprimo.local] |   |   `-- Installing gettext-runtime-0.19.8.1...
[pkg.esprimo.local] |   |   `-- Extracting gettext-runtime-0.19.8.1: .......... done
[pkg.esprimo.local] |   | `-- Extracting gdbm-1.12: .......... done
[pkg.esprimo.local] |   | `-- Installing db5-5.3.28_5...
[pkg.esprimo.local] |   | `-- Extracting db5-5.3.28_5: .......... done
[pkg.esprimo.local] |   `-- Extracting apr-1.5.2.1.5.4_2: .......... done
[pkg.esprimo.local] `-- Extracting serf-1.3.9_1: .......... done
[pkg.esprimo.local] `-- Installing sqlite3-3.14.1_1...
[pkg.esprimo.local] `-- Extracting sqlite3-3.14.1_1: .......... done
[pkg.esprimo.local] Extracting subversion-1.9.4: .......... done
===>   portdowngrade-1.5 depends on executable: svn - found
===>   Returning to build of portdowngrade-1.5
===========================================================================
=======================<phase: stage          >============================
===>  Staging for portdowngrade-1.5
The only options I have disabled are
Code:
OPTIONS_UNSET+=DOCS
OPTIONS_UNSET+=NLS
Therefore it should work as you have expected already. May be the exact command you have entered would give some idea what went wrong.
P.S. I have edited the text a few times because of tag errors I did not found sooner.
 
Top