Solved External USB audio interface

jbodenmann

Well-Known Member

Reaction score: 151
Messages: 311

I have a Fiio Olympus 2 audio interface (USB 2.0 -> 3.5mm jack) and would like to play audio through it (in FreeBSD 13.0).

I've loaded the `snd_driver` metadriver which loaded in a bunch of audio drivers.
Here's the output of cat /dev/sndstat:
Code:
Installed devices:
pcm0: <NVIDIA (0x0083) (HDMI/DP 8ch)> (play)
pcm1: <NVIDIA (0x0083) (HDMI/DP 8ch)> (play)
pcm2: <NVIDIA (0x0083) (HDMI/DP 8ch)> (play)
pcm3: <NVIDIA (0x0083) (HDMI/DP 8ch)> (play)
pcm4: <Realtek ALC1220 (Rear Analog 5.1/2.0)> (play/rec)
pcm5: <Realtek ALC1220 (Front Analog)> (play/rec)
pcm6: <Realtek ALC1220 (Rear Digital)> (play)
pcm7: <USB audio> (play/rec) default
pcm8: <USB audio> (play/rec)
No devices installed from userspace.

I take it that pcm7 and pcm8 are provided by said audio interface.

After ensuring that the volume(s) for these two devices are at a decent level (75) using audio/mixertui I tried playing audio first naively by just playing a YouTube video via Firefox and later by using mpg123 path_to_some.mp3.

Unfortunately I am unable to get any audio out of this device.
I know for sure that the device itself is working as it works well under Windows 10.

Where should I go from here? How can I verify that any of the loaded drivers actually work for this device? Is there anything else I am missing given that this is a USB device? Anything else?
 
OP
jbodenmann

jbodenmann

Well-Known Member

Reaction score: 151
Messages: 311

That appears to be the case, yes.
This must have been pulled in by some other program as a dependency as I don't recall having installed it manually.

Disclaimer: I am brand new to using FreeBSD on a Desktop. I only ran FreeBSD on server so far and never needed any audio stuff.
 

Alexander88207

Aspiring Daemon

Reaction score: 493
Messages: 709

Every time you change the audio device pulseaudio must be restarted with pulseaudio -k and the internet page or even the browser must be restarted.

But should not be the case for audio/mpg123.el
 
OP
jbodenmann

jbodenmann

Well-Known Member

Reaction score: 151
Messages: 311

btw, is there a way to figure out which driver I need for this sound card so I don't have to load all the other drivers via `snd_driver`?
 

Alexander88207

Aspiring Daemon

Reaction score: 493
Messages: 709

btw, is there a way to figure out which driver I need for this sound card so I don't have to load all the other drivers via `snd_driver`?

FreeBSD automatically loads the required driver. Is this not the case for you?
 
OP
jbodenmann

jbodenmann

Well-Known Member

Reaction score: 151
Messages: 311

Yep, seems to work indeed.
Should/would/can somebody update the handbook?
 
Top