1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

external hard-disk ain't recognized

Discussion in 'Peripheral Hardware' started by Anonymous, Apr 25, 2010.

  1. Anonymous

    Anonymous Guest

    I just attached my external hard-disk (with usb) and can't recognize it with fdisk.
    I checked dmesg:
    root:# dmesg | tail
    info: [drm] Initialized i915 1.6.0 20080730
    drm0: [ITHREAD]
    ugen3.2: <Sunplus Technology Inc.> at usbus3
    umass0: <Bulk Only Interface> on usbus3
    umass0:  SCSI over Bulk-Only; quirks = 0x4000
    umass0:0:0:-1: Attached to scbus0
    (da0:umass-sim0:0:0:0): got CAM status 0x4
    (da0:umass-sim0:0:0:0): fatal error, failed to attach to device
    (da0:umass-sim0:0:0:0): lost device
    (da0:umass-sim0:0:0:0): removing device entry

    Whats wrong?
  2. MG

    MG New Member

    Thanks Received:
    Maybe your USB port has not enough power. I have an external disk with 2 connectors. On some computers I see this message when only one is plugged in.
  3. Anonymous

    Anonymous Guest

    Aha. That might be. Its a rather old PC.
  4. fbsd1

    fbsd1 New Member

    Thanks Received:
    check the ribbon cable nipple is correctly pluged into the HD. I got that same error when the nipple was one row of pins off.
  5. Anonymous

    Anonymous Guest

    With Debian i may mount the HD just fine (on the same PC, its dual-boot). So it is rather that i am doing it wrong the BSD-way than something hardware-related.
  6. fronclynne

    fronclynne New Member

    Thanks Received:
    It looks to m[e|y inexpert eye] like your USB->ATA chip doesn't play nicely with FreeBSD. I dunno if you'll be best off with the freebsd-usb@ list, or hackers, or here, or what, though. Sorry.
  7. none

    none Member

    Thanks Received:
    I have a external usb to ide that was ok in 7.x days, and now is not. a PR is already filed for that.

  8. SirDice

    SirDice Moderator Staff Member Moderator

    Thanks Received:
    Try unplugging it and plugging it back in. I had a similar issue last night with a brand new 2TB external drive. First time it just refused to recognize it. After the unplug/plug it worked.
  9. Anonymous

    Anonymous Guest

    I read the advices here, so i tried it again (plugged and un-plugged a few times).
    To make it short: i was able to mount it.

    As 'fdisk' didn't show it i ran 'dmesg'. The last two lines were:
    xptioctl: pass driver is not in the kernel
    xptioctl: put "device pass" in your kernel config file

    A search gave me this:
    I did ran the command to be found there:
    /etc/rc.d/devd restart  

    (which gave me errors, but /dev/da0 showed up in 'dmesg') and a final:
    mount -t ext2fs /da0s2 

    mounted it.

    I still don't understand the output of 'fdisk', but i for one can't find the device here:
    ROOT# fdisk
    ******* Working on device /dev/ad0 *******
    parameters extracted from in-core disklabel are:
    cylinders=77622 heads=16 sectors/track=63 (1008 blks/cyl)
    Figures below won't work with BIOS for partitions not in cyl 1
    parameters to be used for BIOS calculations are:
    cylinders=77622 heads=16 sectors/track=63 (1008 blks/cyl)
    Media sector size is 512
    Warning: BIOS sector numbering starts with sector 1
    Information from DOS bootblock is:
    The data for partition 1 is:
    sysid 165 (0xa5),(FreeBSD/NetBSD/386BSD)
        start 63, size 57721041 (28184 Meg), flag 80 (active)
    	beg: cyl 0/ head 1/ sector 1;
    	end: cyl 1023/ head 15/ sector 63
    The data for partition 2 is:
    The data for partition 3 is:
    The data for partition 4 is:
    sysid 5 (0x05),(Extended DOS)
        start 57721545, size 20515005 (10017 Meg), flag 0
    	beg: cyl 1023/ head 255/ sector 63;
    	end: cyl 1023/ head 9/ sector 63

    Thanks for the help.
  10. Beastie

    Beastie Active Member

    Thanks Received:
    Your desktop environment may be automounting it. Are you sure it's mounted? Does it show up when you execute the command % mount?

    Besides, unless you already have an entry for da0 in /etc/fstab, you will need to specify a mountpoint, e.g. # mount -t ext2fs /da0s2 /mountpoint.

    And BTW, if you execute fdisk(8) without specifying a device, it will use the default one, i.e. your system disk (in this case ad0). Try % fdisk da0.
  11. Anonymous

    Anonymous Guest

    I am using e17. It doesn't automount per default. Might be i may set it that way, but i don't want to.

    My fault, a typo. The command i used was:
    mount -t ext2fs /dev/da0s2 /media/disk

    So yes, it is mounted (i am listening to my music from it, so i am pretty sure).
    Aha. Good info, now i got it.
    So there ain't a similar command to the 'fdisk -l' of linux (which shows all the devices at once)?

    Thank you.