Solved /etc/rc.conf: devfs_system_ruleset: not found

During this last week, I have been testing the FreeBSD 11.0-RELEASE on an old refurbished PC I use for testing out new systems. It is dual-booting with Linux MINT and there have been few problems until 2 days ago. I tried to install a new conky screen monitor and used a custom version (of the conky configuration file) to replace the default file located at: /usr/local/share/examples/conky/conky.conf.

The first boot after the changes were made I had a kernel panic, and the dreaded "black screen of death".
I used Ctrl + C then switched to root privileges to run < # fsck -f >. There were four bad blocks, and some data requests were not salvaged, However, the system did boot successfully on all successive boot sessions.

So, basically, on a new system startup a message flashes: "../etc/rc.conf: devfs_system_ruleset: not found."
In addition, the new custom version of conky has never successfully launched; the default conky version does launch.

Any insight on this situation would be appreciated!
 
Fsck does not check for bad block, only for filesystem metadata corruption. How did you come to the conclusion that the disk has bad blocks? If it does really have bad blocks then the only course of action is to replace the disk but you haven't provided enough information to make a call one way or another.
 
Okay, I checked some of my notes from 2 days ago, and the data corruption (metadata) was not salvaged, from the fsck(8) command. But nothing about bad blocks, sorry about that. Dual-booting machines probably have competition for command of hardware devices operation. In addition, I probably have not installed debugging kernels, nor crash dumping tools, yet.

What sort of /var/log files or X.org files would help?
 
It turns out, that the four bad blocks were indeed a damaged hard drive. The system had a fatal I/O trap error and crashed the BIOS on the next boot attempt. So, replaced the hard drive yesterday, and rebuilding the system from scratch.
 
Rebuilt the FreeBSD 11.0-RELEASE with the device filesystem ruleset enabled and running again! (Fresh hard drive)
 
Back
Top