"error resolving pool 0.freebsd.pool.ntp.org" at startup

johnblue

Well-Known Member

Reaction score: 43
Messages: 326

This is a 12.0 vm install from .iso on vmware that has been updated to p6.

ntpdate and ntpd are enabled in rc.conf but ntpd complains that it cannot resolve "0.freebsd.pool.ntp.org" during startup.
However, when I manually stop and restart ntpd it is able to resolve it:
Code:
named[611]: running
ntpd[692]: ntpd 4.2.8p12-a (1): Starting
ntpd[693]: error resolving pool 0.freebsd.pool.ntp.org: hostname nor servname provided, or not known (8)
su[807]: john.blue to root on /dev/pts/0
ntpd[693]: ntpd exiting on signal 15 (Terminated)
ntpd[830]: ntpd 4.2.8p12-a (1): Starting

I have tried different nameserver settings in resolv.conf .. GUI, RFC1918 and 127.0.0.1. While all nameserver settings work, resolving on startup does not. I have also disabled pf from starting without success.

It feels like it is going to be something obvious that I have missed but right now, at this late hour, I am not seeing it.

TIA
 

m0nkey_

Member

Reaction score: 13
Messages: 32

Same here on 12. I tried switching to chrony which does the same thing as ntpd, but its patient and waits until DNS is available.
 

gustopn

Member

Reaction score: 3
Messages: 66

DNS is available all the time. You can try that by service ntpd restart and you will see the same problem.
It think chrony may be trying a different name resolving route and that makes it work then.
 
Top