Error # portmaster -avGD / Upgrade py38-pycparser-2.20 to py38-pycparser-2.21

heraldo

New Member

Reaction score: 2
Messages: 12

I use CCACHE...
Code:
# portsnap auto
# portmaster -avGD
...
===>>> All >> (14)

===>>> The following actions will be taken if you choose to proceed:
    Upgrade py38-pycparser-2.20 to py38-pycparser-2.21
    Upgrade py38-pyparsing-3.0.4 to py38-pyparsing-3.0.6
    Upgrade py38-snowballstemmer-2.1.0 to py38-snowballstemmer-2.2.0
    Upgrade vulkan-loader-1.2.199 to vulkan-loader-1.2.199_1
    Upgrade webkit2-gtk3-2.34.1_1 to webkit2-gtk3-2.34.2
    Upgrade wpebackend-fdo-1.10.0 to wpebackend-fdo-1.12.0
    Upgrade meson-0.60.1_1 to meson-0.60.2
    Upgrade firefox-esr-91.3.0_2,1 to firefox-esr-91.4.0,1
    Upgrade git-2.33.1 to git-2.34.1
    Upgrade rxvt-unicode-9.26 to rxvt-unicode-9.30
    Install sysutils/libptytty
    Upgrade virtualbox-ose-6.1.28_1 to virtualbox-ose-6.1.30
    Upgrade virtualbox-ose-additions-6.1.28 to virtualbox-ose-additions-6.1.30
    Upgrade vlc-3.0.16_7,4 to vlc-3.0.16_8,4

===>>> Proceed? y/n [y] 
...

===>  License BSD3CLAUSE accepted by the user
===>   py38-pycparser-2.21 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by py38-pycparser-2.21 for building
===>  Extracting for py38-pycparser-2.21
=> SHA256 Checksum OK for pycparser-2.21.tar.gz.
===>  Patching for py38-pycparser-2.21
===>   py38-pycparser-2.21 depends on package: py38-setuptools>0 - found
===>   py38-pycparser-2.21 depends on file: /usr/local/bin/python3.8 - found
===>  Configuring for py38-pycparser-2.21
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 35, in <module>
    setup(
  File "/usr/local/lib/python3.8/site-packages/setuptools/__init__.py", line 153, in setup
    return distutils.core.setup(**attrs)
  File "/usr/local/lib/python3.8/distutils/core.py", line 108, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/local/lib/python3.8/site-packages/setuptools/dist.py", line 455, in __init__
    _Distribution.__init__(self, {
  File "/usr/local/lib/python3.8/distutils/dist.py", line 292, in __init__
    self.finalize_options()
  File "/usr/local/lib/python3.8/site-packages/setuptools/dist.py", line 800, in finalize_options
    for ep in sorted(eps, key=by_order):
  File "/usr/local/lib/python3.8/site-packages/setuptools/dist.py", line 799, in <lambda>
    eps = map(lambda e: e.load(), pkg_resources.iter_entry_points(group))
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2449, in load
    self.require(*args, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2472, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'packaging>=20.0' distribution was not found and is required by the application
*** Error code 1

Stop.
make: stopped in /usr/ports/devel/py-pycparser

===>>> make build failed for devel/py-pycparser@py38
===>>> Aborting update

===>>> Update for devel/py-pycparser@py38 failed
===>>> Aborting update


===>>> You can restart from the point of failure with this command line:
       portmaster <flags> devel/py-pycparser@py38 devel/py-pyparsing@py38 textproc/py-snowballstemmer@py38 graphics/vulkan-loader www/webkit2-gtk3 www/wpebackend-fdo devel/meson www/firefox-esr devel/git@default x11/rxvt-unicode sysutils/libptytty emulators/virtualbox-ose emulators/virtualbox-ose-additions multimedia/vlc 

This command has been saved to ~/portmasterfail.txt








[root@n43s /usr/ports]# cd /usr/ports/devel/py-pycparser
[root@n43s /usr/ports/devel/py-pycparser]# make
===>   py38-pycparser-2.21 depends on package: py38-setuptools>0 - found
===>   py38-pycparser-2.21 depends on file: /usr/local/bin/python3.8 - found
===>  Configuring for py38-pycparser-2.21
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "setup.py", line 35, in <module>
    setup(
  File "/usr/local/lib/python3.8/site-packages/setuptools/__init__.py", line 153, in setup
    return distutils.core.setup(**attrs)
  File "/usr/local/lib/python3.8/distutils/core.py", line 108, in setup
    _setup_distribution = dist = klass(attrs)
  File "/usr/local/lib/python3.8/site-packages/setuptools/dist.py", line 455, in __init__
    _Distribution.__init__(self, {
  File "/usr/local/lib/python3.8/distutils/dist.py", line 292, in __init__
    self.finalize_options()
  File "/usr/local/lib/python3.8/site-packages/setuptools/dist.py", line 800, in finalize_options
    for ep in sorted(eps, key=by_order):
  File "/usr/local/lib/python3.8/site-packages/setuptools/dist.py", line 799, in <lambda>
    eps = map(lambda e: e.load(), pkg_resources.iter_entry_points(group))
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2449, in load
    self.require(*args, **kwargs)
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2472, in require
    items = working_set.resolve(reqs, env, installer, extras=self.extras)
  File "/usr/local/lib/python3.8/site-packages/pkg_resources/__init__.py", line 772, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'packaging>=20.0' distribution was not found and is required by the application
*** Error code 1

Stop.
Any suggestion?
 

Alain De Vos

Son of Beastie

Reaction score: 869
Messages: 2,826

1. Verify that the ports source tree is good in sync with the branch 2021Q4 or main.

2.I have the following line in make.conf to hint the python version to use:
Code:
DEFAULT_VERSIONS+=python3=3.8
 

covacat

Daemon

Reaction score: 515
Messages: 1,040

there was similar error in a recent thread
i think the solution was update/install py-packaging (again)
 

Jose

Daemon

Reaction score: 1,153
Messages: 1,368

From the freebsd-ports email list:
If I remember correctly, the fix is to de-install both py38-packaging and
py38-setuptools.
> pkg delete -f py38-setuptools
> pkg delete -f py38-packaging
> portmaster devel/py-packaging
> portmaster devel/py-setuptools

This assumes the use of portmaster, but it should work with whichever tool
you use.

The problem was that a function was moved between ports and, as a result,
you can't build either port when the old version of either is installed.
 
Last edited:

pantos

New Member

Reaction score: 1
Messages: 13

Thanks! Important: there is a false port in the mail. You have to install devel/py-packaging. Port devel/pkg-packaging doesn't exist.

Aside from that I have to make a make install clean in devel/py-packaging. Portmaster abort the installation via portmaster devel/py-packaging.
 
Top