• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Error message when booting (USB_ERR_TIMEOUT, ignored)

s5e

New Member


Messages: 15

#1
Fresh install and I get error message when booting:
Code:
usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_TIMEOUT, ignored)
usbd_setup_device_desc: getting device descriptor at addr 3 failed, USB_ERR_TIMEOUT
What this means?
 

fullauto2012

Active Member

Thanks: 27
Messages: 161

#2
post your hardware specs and what version of FreeBSD you are running.
 

s5e

New Member


Messages: 15

#4
From /var/log/messages
Code:
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usb_alloc_device: set address 3 failed (USB_ERR_TIMEOUT, ignored)
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_setup_device_desc: getting device descriptor at addr 3 failed, USB_ERR_TIMEOUT
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_TIMEOUT, ignored)
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_setup_device_desc: getting device descriptor at addr 3 failed, USB_ERR_TIMEOUT
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_TIMEOUT, ignored)
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_setup_device_desc: getting device descriptor at addr 3 failed, USB_ERR_TIMEOUT
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_TIMEOUT, ignored)
Jan 11 12:28:43 hpenvy kernel: usbd_setup_device_desc: getting device descriptor at addr 3 failed, USB_ERR_TIMEOUT
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_req_re_enumerate: addr=3, set address failed! (USB_ERR_TIMEOUT, ignored)
Jan 11 12:28:43 hpenvy kernel: Root mount waiting for: usbus0
Jan 11 12:28:43 hpenvy kernel: usbd_setup_device_desc: getting device descriptor at addr 3 failed, USB_ERR_TIMEOUT
Jan 11 12:28:43 hpenvy kernel: ugen0.3: <Unknown > at usbus0 (disconnected)
Jan 11 12:28:43 hpenvy kernel: uhub_reattach_port: could not allocate new device
Jan 11 12:28:43 hpenvy kernel: ugen0.3: <vendor 0x138a product 0x0050> at usbus0
Code:
% sudo usbconfig
ugen0.1: <0x8086 XHCI root HUB> at usbus0, cfg=0 md=HOST spd=SUPER (5.0Gbps) pwr=SAVE (0mA)
ugen0.2: <Generic HP Truevision HD> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (500mA)
ugen0.3: <vendor 0x138a product 0x0050> at usbus0, cfg=0 md=HOST spd=FULL (12Mbps) pwr=ON (100mA)
ugen0.4: <Generic Mass Storage> at usbus0, cfg=0 md=HOST spd=HIGH (480Mbps) pwr=ON (200mA)
(ugen0.4 is memorystick, so usb seems to work somehow.)

Code:
% pciconf -lv
hostb0@pci0:0:0:0:   class=0x060000 card=0x80df103c chip=0x19048086 rev=0x08 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers'
   class      = bridge
   subclass   = HOST-PCI
vgapci0@pci0:0:2:0:   class=0x030000 card=0x80df103c chip=0x19168086 rev=0x07 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Skylake GT2 [HD Graphics 520]'
   class      = display
   subclass   = VGA
none0@pci0:0:4:0:   class=0x118000 card=0x80df103c chip=0x19038086 rev=0x08 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem'
   class      = dasp
xhci0@pci0:0:20:0:   class=0x0c0330 card=0x80df103c chip=0x9d2f8086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP USB 3.0 xHCI Controller'
   class      = serial bus
   subclass   = USB
none1@pci0:0:20:2:   class=0x118000 card=0x80df103c chip=0x9d318086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP Thermal subsystem'
   class      = dasp
none2@pci0:0:21:0:   class=0x118000 card=0x80df103c chip=0x9d608086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP Serial IO I2C Controller'
   class      = dasp
none3@pci0:0:21:1:   class=0x118000 card=0x80df103c chip=0x9d618086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP Serial IO I2C Controller'
   class      = dasp
none4@pci0:0:22:0:   class=0x078000 card=0x80df103c chip=0x9d3a8086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP CSME HECI'
   class      = simple comms
ahci0@pci0:0:23:0:   class=0x010601 card=0x80df103c chip=0x9d038086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP SATA Controller [AHCI mode]'
   class      = mass storage
   subclass   = SATA
pcib1@pci0:0:28:0:   class=0x060400 card=0x80df103c chip=0x9d158086 rev=0xf1 hdr=0x01
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP PCI Express Root Port'
   class      = bridge
   subclass   = PCI-PCI
pcib2@pci0:0:29:0:   class=0x060400 card=0x80df103c chip=0x9d188086 rev=0xf1 hdr=0x01
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP PCI Express Root Port'
   class      = bridge
   subclass   = PCI-PCI
isab0@pci0:0:31:0:   class=0x060100 card=0x80df103c chip=0x9d488086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP LPC Controller'
   class      = bridge
   subclass   = PCI-ISA
none5@pci0:0:31:2:   class=0x058000 card=0x80df103c chip=0x9d218086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP PMC'
   class      = memory
hdac0@pci0:0:31:3:   class=0x040300 card=0x80df103c chip=0x9d708086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP HD Audio'
   class      = multimedia
   subclass   = HDA
none6@pci0:0:31:4:   class=0x0c0500 card=0x80df103c chip=0x9d238086 rev=0x21 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Sunrise Point-LP SMBus'
   class      = serial bus
   subclass   = SMBus
iwm0@pci0:1:0:0:   class=0x028000 card=0x50108086 chip=0x095a8086 rev=0x61 hdr=0x00
   vendor     = 'Intel Corporation'
   device     = 'Wireless 7265'
   class      = network
none7@pci0:2:0:0:   class=0xff0000 card=0x80df103c chip=0x522a10ec rev=0x01 hdr=0x00
   vendor     = 'Realtek Semiconductor Co., Ltd.'
   device     = 'RTS522A PCI Express Card Reader'
 

tingo

Daemon

Thanks: 275
Messages: 1,730

#5
For some reason, the machine is unable to use your usb stick properly (it should end up attached as a storage device, not just ugen*.*). The general advice in these situations is to try a different usb stick (different brand, different model). Also try another usb port if you have more than one.

The pciconf output only shows a usb 3.0 hub (xhci), I would expect to see usb 2.x hubs as well (uhci, ohci), but I don't know if this is a problem.